summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/yelp')
-rw-r--r--gnome-extra/yelp/Manifest1
-rw-r--r--gnome-extra/yelp/files/yelp-3.0.3-man-compatibility.patch117
-rw-r--r--gnome-extra/yelp/yelp-3.16.1.ebuild51
3 files changed, 0 insertions, 169 deletions
diff --git a/gnome-extra/yelp/Manifest b/gnome-extra/yelp/Manifest
index 19425384d218..2ca8d69839d6 100644
--- a/gnome-extra/yelp/Manifest
+++ b/gnome-extra/yelp/Manifest
@@ -1,2 +1 @@
-DIST yelp-3.16.1.tar.xz 1416752 SHA256 60810b8ddf5d2bf525a70a80a982af5053db061e0d823ed883d3671d9a5267ca SHA512 bfbce5c86dd6ee6d95cd4fc14acf8285616f4aef52b14d0b68f6844fbdad17631c84c2bc029e7ee0599055c00dd8599bf20341686290060b8c27ffddc2265103 WHIRLPOOL bab7e1f4297bcef0896a497c3d2a8d016405a77f77ae9810c80425dfb7234f018e6eb4688f2c408e9a71408684d107fef4de113bb007a0fe7f0850ba4d6a6e87
DIST yelp-3.18.1.tar.xz 1386044 SHA256 ba3a4eb4717c0ecf4a2e40eff0963fcd12c700c4fb80b83ecaad8b7032256880 SHA512 ebff55bb3eb0caad208abfad3d83fa996d63bb97647ff446d25590b5c84d341161f3fdb9987353bd55e73ef2634baa692928fbc21b4ed16b6070500228fc2425 WHIRLPOOL 2f7479641bea73e248508a51e056eb33c9e3c30994017b8c17dfb0153a71f6174152aa8c05dd76fbb4bcc06b72a92bbc1fc46a7c10b19c3b5a62d597390aa3f5
diff --git a/gnome-extra/yelp/files/yelp-3.0.3-man-compatibility.patch b/gnome-extra/yelp/files/yelp-3.0.3-man-compatibility.patch
deleted file mode 100644
index b57591c14ca6..000000000000
--- a/gnome-extra/yelp/files/yelp-3.0.3-man-compatibility.patch
+++ /dev/null
@@ -1,117 +0,0 @@
-From 7e181e8d74f7e67b8b3acb8524fc85157ed39c8e Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gmail.com>
-Date: Sun, 1 May 2011 22:52:14 -0400
-Subject: [PATCH] Enable compatibility with traditional man (#648854)
-
-As of commit 46a82ade3e6f0fac8f08b18e7fc23d8665f6f728, Yelp runs
-"man -Z -Tutf8 -EUTF-8 [FILE]" to obtain the groff intermediate format
-of the man page. However, the only implementation of man that accepts
-these options is man-db (used by Debian, Fedora, SUSE & Ubuntu).
-The traditional Linux man used by other distros and man implementations
-on non-Linux Unixes (FreeBSD, Solaris) do not have command-line options
-for outputting groff intermediate format.
-Therefore, on systems that do not use man-db, we need to manually
-uncompress the nroff source file and feed it to groff. This is best done
-using a small shell script (/usr/libexec/yelp-groff), both for for
-clarity and for ease of modification on systems with weird man setups.
-
-Signed-off-by: Alexandre Rostovtsev <tetromino@gmail.com>
----
- libyelp/Makefile.am | 2 +
- libyelp/yelp-groff | 49 +++++++++++++++++++++++++++++++++++++++++++++
- libyelp/yelp-man-parser.c | 4 +-
- 3 files changed, 53 insertions(+), 2 deletions(-)
- create mode 100755 libyelp/yelp-groff
-
-diff --git a/libyelp/Makefile.am b/libyelp/Makefile.am
-index a4dd68b..5d55bf1 100644
---- a/libyelp/Makefile.am
-+++ b/libyelp/Makefile.am
-@@ -1,4 +1,5 @@
- lib_LTLIBRARIES = libyelp.la
-+libexec_SCRIPTS = yelp-groff
-
- libyelp_la_SOURCES = \
- yelp-bookmarks.c \
-@@ -49,6 +50,7 @@ endif
- libyelp_la_CFLAGS = \
- $(YELP_CFLAGS) \
- -DDATADIR=\""$(datadir)"\" \
-+ -DLIBEXECDIR=\"$(libexecdir)\" \
- -DYELP_ICON_PATH=\"$(YELP_ICON_PATH)\"
-
- libyelp_la_LIBADD = $(YELP_LIBS)
-diff --git a/libyelp/yelp-groff b/libyelp/yelp-groff
-new file mode 100755
-index 0000000..5348024
---- /dev/null
-+++ b/libyelp/yelp-groff
-@@ -0,0 +1,49 @@
-+#!/bin/sh
-+#
-+# Copyright (c) 2011 Alexandre Rostovtsev <tetromino@gmail.com>
-+#
-+# This program is free software; you can redistribute it and/or
-+# modify it under the terms of the GNU General Public License as
-+# published by the Free Software Foundation; either version 2 of the
-+# License, or (at your option) any later version.
-+#
-+# This program is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+# General Public License for more details.
-+#
-+# You should have received a copy of the GNU General Public
-+# License along with this program; if not, write to the
-+# Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-+# Boston, MA 02110-1301, USA.
-+#
-+###
-+#
-+# Process the requested compressed source nroff file and output groff
-+# intermediate format.
-+#
-+
-+filename=$1
-+
-+if [ -z ${filename} ] ; then
-+ echo "Usage: yelp-groff [FILE]" >&2
-+ echo "Process a man FILE and output groff intermediate format."
-+ exit 1
-+fi
-+
-+# If "man -Z -Tutf8 -EUTF-8" works (i.e. if man is man-db), use that.
-+man -Z -Tutf8 -EUTF-8 ${filename} 2>/dev/null && exit 0
-+
-+# Otherwise, manually uncompress the file ...
-+cat="cat"
-+case ${filename} in
-+ *.bz2) cat="bzip2 -c -d" ;;
-+ *.gz) cat="gunzip -c" ;;
-+ *.lzma) cat="unlzma -c -d" ;;
-+ *.xz) cat="unxz -c" ;;
-+ *.Z) cat="zcat" ;;
-+esac
-+
-+# ... and run groff to get the intermediate format; preprocess with tbl
-+# unless MANROFFSEQ is defined.
-+${cat} ${filename} | groff -${MANROFFSEQ:-t} -man -Z -Tutf8
-diff --git a/libyelp/yelp-man-parser.c b/libyelp/yelp-man-parser.c
-index 4001d38..9818803 100644
---- a/libyelp/yelp-man-parser.c
-+++ b/libyelp/yelp-man-parser.c
-@@ -371,9 +371,9 @@ get_troff (gchar *path, GError **error)
- {
- gint stdout;
- GError *err = NULL;
-- gchar *argv[] = { "man", "-Z", "-Tutf8", "-EUTF-8", NULL, NULL };
-+ gchar *argv[] = { LIBEXECDIR "/yelp-groff", NULL, NULL };
-
-- argv[4] = path;
-+ argv[1] = path;
-
- if (!g_spawn_async_with_pipes (NULL, argv, NULL,
- G_SPAWN_SEARCH_PATH, NULL, NULL,
---
-1.7.5.rc3
-
diff --git a/gnome-extra/yelp/yelp-3.16.1.ebuild b/gnome-extra/yelp/yelp-3.16.1.ebuild
deleted file mode 100644
index 0fa0370ff129..000000000000
--- a/gnome-extra/yelp/yelp-3.16.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-
-inherit autotools eutils gnome2
-
-DESCRIPTION="Help browser for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE=""
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-
-RDEPEND="
- app-arch/bzip2:=
- >=app-arch/xz-utils-4.9:=
- dev-db/sqlite:3=
- >=dev-libs/glib-2.38:2
- >=dev-libs/libxml2-2.6.5:2
- >=dev-libs/libxslt-1.1.4
- >=gnome-extra/yelp-xsl-3.12
- >=net-libs/webkit-gtk-1.3.10:3
- >=x11-libs/gtk+-3.13.3:3
- x11-themes/gnome-icon-theme-symbolic
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.13
- >=dev-util/intltool-0.41.0
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
-"
-
-src_prepare() {
- # Fix compatibility with Gentoo's sys-apps/man
- # https://bugzilla.gnome.org/show_bug.cgi?id=648854
- epatch "${FILESDIR}"/${PN}-3.16.0-man-compatibility.patch
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --enable-bz2 \
- --enable-lzma \
- ITSTOOL=$(type -P true)
-}