summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/yelp')
-rw-r--r--gnome-extra/yelp/Manifest1
-rw-r--r--gnome-extra/yelp/yelp-40.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/yelp/Manifest b/gnome-extra/yelp/Manifest
index df486f30159d..02697bd01765 100644
--- a/gnome-extra/yelp/Manifest
+++ b/gnome-extra/yelp/Manifest
@@ -1 +1,2 @@
DIST yelp-40.0.tar.xz 1526456 BLAKE2B de76ce11775b2940a5590a72a0f9f821a3b083810087c65f870cfaf4d6bb0a34653025d87b28d01e11ce5e3dbd7bca8331c62d701d8c050938756c53797198d0 SHA512 efe88bc8d75d00b48b8a0a8d2a07cc95771a4fd8e7068003333f79336f1272f07f1738d91a6978e3c3a9258c6742551d25e8cd899a77cfa262f22e6cf9632590
+DIST yelp-40.2.tar.xz 1527112 BLAKE2B e588b533cd3b59c200904a54bdb2e1ecea620e447ddbae3645252f134fd0f92fb920b512ff7d27d213307b6bc5bec333faafab291af872681813f710de03a587 SHA512 adb6f5781c13cf7b91c0b2b97a34a271d7f72328a8affb379342aedf6cb0c8ed72f5874b0d67802bab6be9a3e1ad77910c8be872724c89477454d35043c5453c
diff --git a/gnome-extra/yelp/yelp-40.2.ebuild b/gnome-extra/yelp/yelp-40.2.ebuild
new file mode 100644
index 000000000000..ddb5e4d5603f
--- /dev/null
+++ b/gnome-extra/yelp/yelp-40.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ app-arch/bzip2:=
+ >=app-arch/xz-utils-4.9:=
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=gnome-extra/yelp-xsl-3.27.1
+ >=net-libs/webkit-gtk-2.19.2:4
+ >=x11-libs/gtk+-3.13.3:3
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ >=dev-util/gtk-doc-am-1.13
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch # needs eautoreconf
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-bz2 \
+ --enable-lzma \
+ APPSTREAM_UTIL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ exeinto /usr/libexec/
+ doexe "${S}"/libyelp/yelp-groff
+}