summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/sogo/Manifest1
-rw-r--r--gnustep-apps/sogo/files/sogod.confd6
-rw-r--r--gnustep-apps/sogo/files/sogod.initd33
-rw-r--r--gnustep-apps/sogo/metadata.xml16
-rw-r--r--gnustep-apps/sogo/sogo-2.3.2.ebuild99
5 files changed, 155 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/Manifest b/gnustep-apps/sogo/Manifest
new file mode 100644
index 000000000000..a288fdb12e5e
--- /dev/null
+++ b/gnustep-apps/sogo/Manifest
@@ -0,0 +1 @@
+DIST sogo-2.3.2.tar.gz 11440737 SHA256 236812a74afdd388a10edd9b2db27f4bf8e05818d5ddd65fea9b1b43e6c7a223 SHA512 a91a710af1c36e3becf250c60e1430a012b98e9026957c9faf6c7cddc526273296f00d9df2e7c8c830887a96dfa2576ffd2dd0dfb1ed3e6fc6bfa1b9f100b792 WHIRLPOOL 66fcd37f012923f4f500f6b961dface5dab47b99e89788660728274fc752ad229b5728408e5846450e40e8bf17a54c73372ee0a9ab6666e3b100c05cd7f24cad
diff --git a/gnustep-apps/sogo/files/sogod.confd b/gnustep-apps/sogo/files/sogod.confd
new file mode 100644
index 000000000000..906a6978d862
--- /dev/null
+++ b/gnustep-apps/sogo/files/sogod.confd
@@ -0,0 +1,6 @@
+# /etc/conf.d/sogod: config file for /etc/init.d/sogod
+
+SOGOD_WORKERS=3
+
+# Additional options for SOGo
+SOGOD_OPTS=""
diff --git a/gnustep-apps/sogo/files/sogod.initd b/gnustep-apps/sogo/files/sogod.initd
new file mode 100644
index 000000000000..c0dfcdc0c0c7
--- /dev/null
+++ b/gnustep-apps/sogo/files/sogod.initd
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SOGOD_PID=/run/sogo/sogod.pid
+
+depend() {
+ need net
+ need memcached
+ after postgresql mysql
+ after slapd
+ after mta
+}
+
+start() {
+ checkpath -q -d -m 0755 -o sogo:sogo $(dirname "${SOGOD_PID}")
+ ebegin "Starting SOGo service"
+ start-stop-daemon --start --quiet \
+ --user sogo --exec /usr/sbin/sogod \
+ -- -WOWorkersCount ${SOGOD_WORKERS} \
+ -WOLogFile /var/log/sogo/sogod.log \
+ -WOPidFile "${SOGOD_PID}" \
+ "${SOGOD_OPTS}"
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping SOGo service"
+ start-stop-daemon --stop \
+ --pidfile "${SOGOD_PID}"
+ eend ${?}
+}
diff --git a/gnustep-apps/sogo/metadata.xml b/gnustep-apps/sogo/metadata.xml
new file mode 100644
index 000000000000..f3cc8a88c46c
--- /dev/null
+++ b/gnustep-apps/sogo/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type='github'>inverse-inc/sogo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gnustep-apps/sogo/sogo-2.3.2.ebuild b/gnustep-apps/sogo/sogo-2.3.2.ebuild
new file mode 100644
index 000000000000..e11cbe4d7b12
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-2.3.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit gnustep-2 user vcs-snapshot
+
+DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://www.sogo.nu"
+SRC_URI="https://github.com/inverse-inc/sogo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls libressl +ssl"
+
+RDEPEND="
+ dev-libs/libmemcached
+ net-misc/curl
+ net-misc/memcached
+ >=gnustep-libs/sope-${PV}[ldap]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.2"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+pkg_setup() {
+ enewuser sogo -1 /bin/bash /var/lib/sogo
+}
+
+src_prepare() {
+ gnustep-base_src_prepare
+ sed -e "s/validateArgs$//" -i configure \
+ || die "GNUstep.conf sed failed"
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ ./configure \
+ --disable-strip \
+ --prefix=/usr \
+ --with-ssl="${ssl_provider}" \
+ $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ newconfd "${FILESDIR}"/sogod.confd sogod
+ newinitd "${FILESDIR}"/sogod.initd sogod
+
+ insinto /etc/logrotate.d
+ newins Scripts/logrotate sogo
+ newdoc Apache/SOGo.conf SOGo-Apache.conf
+
+ insinto /etc/sogo
+ doins Scripts/sogo.conf
+
+ insinto /etc/cron.d
+ newins Scripts/sogo.cron sogo
+ keepdir /var/log/sogo
+
+ fowners sogo:sogo /var/log/sogo
+ fowners -R root:sogo /etc/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+ elog "SOGo documentation is available online at:"
+ elog "http://www.sogo.nu/downloads/documentation.html"
+ elog
+ elog "Apache sample configuration file is available in:"
+ elog "/usr/share/doc/${PF}"
+}