summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/Manifest1
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.25.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-base/Manifest b/gnustep-base/gnustep-base/Manifest
index e37555531830..179c611ad6a5 100644
--- a/gnustep-base/gnustep-base/Manifest
+++ b/gnustep-base/gnustep-base/Manifest
@@ -1 +1,2 @@
DIST gnustep-base-1.24.9.tar.gz 3561094 SHA256 059509f9f646c5b916685e74f0ea2a87fc277b16862177c91228735af1a272ef SHA512 baaa3541edf48a5d902f706f9dad261378bf65e5d89f7308ece6a1fe55c348506df4b6d474ae17cdf0072f1e8dec1b2050d59413abe28bd001d5717c54a3ab96 WHIRLPOOL 59f1b29c956185048129bc0ae89802655d446948552c1708030ad8d66e8264f724d6960d5db9a2026022a6533c49a09b0404705cca7071798815276bf17d1f04
+DIST gnustep-base-1.25.0.tar.gz 3528599 SHA256 f5159a7d70e06b9dfb96c5f8ac572e3a5e6cf8de7bafb056bc9b2e0c4f93c347 SHA512 0c38baa439a87557e054e37ed7b337e9f90f349fd6683551cf6482a0a53c247e2ca23b7df9ab369e8819a7d0f9f29e8a8dc639b148ec1c0223764796dbbd3608 WHIRLPOOL 605085595db42ecfaf759df468b897f5294974cf6dc7e34993cd4e6c4ef341ea50da938203bf1b5efed43b1dccecfd0a604226092c0f50cf414a183b5a1a6e13
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.25.0.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.25.0.ebuild
new file mode 100644
index 000000000000..c4443e1e8360
--- /dev/null
+++ b/gnustep-base/gnustep-base/gnustep-base-1.25.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnustep-base
+
+DESCRIPTION="A library of general-purpose, non-graphical Objective C objects"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="+gnutls +icu +libffi zeroconf"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-make-2.6.0
+ gnutls? ( net-libs/gnutls )
+ icu? ( >=dev-libs/icu-4.0:= )
+ !libffi? ( dev-libs/ffcall
+ gnustep-base/gnustep-make[-native-exceptions] )
+ libffi? ( virtual/libffi )
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.1
+ >=dev-libs/gmp-4.1:=
+ >=sys-libs/zlib-1.2
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ egnustep_env
+
+ local myconf
+ if use libffi ; then
+ myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
+ else
+ myconf="--disable-libffi --enable-ffcall"
+ fi
+
+ myconf="$myconf $(use_enable gnutls tls)"
+ myconf="$myconf $(use_enable icu)"
+ myconf="$myconf $(use_enable zeroconf)"
+ myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
+ myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
+ myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf"
+
+ econf $myconf
+}
+
+src_install() {
+ # We need to set LD_LIBRARY_PATH because the doc generation program
+ # uses the gnustep-base libraries. Since egnustep_env "cleans the
+ # environment" including our LD_LIBRARY_PATH, we're left no choice
+ # but doing it like this.
+
+ egnustep_env
+ egnustep_install
+
+ if use doc ; then
+ export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
+ egnustep_doc
+ fi
+ egnustep_install_config
+}