summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs/performance')
-rw-r--r--gnustep-libs/performance/Manifest1
-rw-r--r--gnustep-libs/performance/performance-0.5.0.ebuild12
-rw-r--r--gnustep-libs/performance/performance-0.6.0.ebuild26
3 files changed, 33 insertions, 6 deletions
diff --git a/gnustep-libs/performance/Manifest b/gnustep-libs/performance/Manifest
index 80ad5b36f5b4..903b8c2b7408 100644
--- a/gnustep-libs/performance/Manifest
+++ b/gnustep-libs/performance/Manifest
@@ -1 +1,2 @@
DIST Performance-0.5.0.tar.gz 50569 BLAKE2B b79f27fc0974c6005725b916cfb528c15d380b62dea2b846c129fda04e4b56ad33d00c4432d19f0ee9bfa3593cd9fa8781d0dbd168c26cceb9e007054252d7b2 SHA512 ac83d046c801e1c2b69c708fa806cccf40fca4d5dabe5d461524c3c3eea989c939a11e58d8bff177f45e55a3e1be73bd03b0bb80b611c8390560740cd5cf9fd5
+DIST Performance-0.6.0.tar.gz 56850 BLAKE2B 17b2aa0189e8cc9820981fb9c7b784be5011daaccce1faa2ada66e46d84eb178ae1fd75cbc0dacfb82baea451bdad5909e17d0813c116fdce1f801326ae15a1d SHA512 55fa9399800635a7ea65d14bb82704cf43f9d744eb6928af7c984136aa6f98e1de8780a59d579f5d6c5dcd4c60f7cb37dfa2f0ba1b0175ac5b63d24e06f80076
diff --git a/gnustep-libs/performance/performance-0.5.0.ebuild b/gnustep-libs/performance/performance-0.5.0.ebuild
index 5f6bcc8b2665..0f42ec545fcb 100644
--- a/gnustep-libs/performance/performance-0.5.0.ebuild
+++ b/gnustep-libs/performance/performance-0.5.0.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit gnustep-2
MY_P=${P/p/P}
DESCRIPTION="Help improve the performance of GNUstep applications"
-HOMEPAGE="http://wiki.gnustep.org/index.php/Performance"
+HOMEPAGE="https://github.com/gnustep/libs-performance"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="LGPL-3"
+LICENSE="LGPL-3+"
SLOT="0"
-S=${WORKDIR}/${MY_P}
-
src_prepare() {
if ! use doc; then
# Remove doc target
diff --git a/gnustep-libs/performance/performance-0.6.0.ebuild b/gnustep-libs/performance/performance-0.6.0.ebuild
new file mode 100644
index 000000000000..0f42ec545fcb
--- /dev/null
+++ b/gnustep-libs/performance/performance-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnustep-2
+
+MY_P=${P/p/P}
+DESCRIPTION="Help improve the performance of GNUstep applications"
+HOMEPAGE="https://github.com/gnustep/libs-performance"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e '/documentation\.make/d' GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ default
+}