summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild36
-rw-r--r--gnustep-libs/gsldap/gsldap-0.0.1_pre20070219-r1.ebuild9
-rw-r--r--gnustep-libs/netclasses/netclasses-1.1.0-r1.ebuild16
-rw-r--r--gnustep-libs/pantomime/pantomime-1.4.0.ebuild11
-rw-r--r--gnustep-libs/performance/performance-0.5.0.ebuild12
-rw-r--r--gnustep-libs/renaissance/renaissance-0.9.0-r2.ebuild17
-rw-r--r--gnustep-libs/sope/sope-5.1.1-r1.ebuild4
-rw-r--r--gnustep-libs/sope/sope-5.2.0-r1.ebuild4
-rw-r--r--gnustep-libs/sqlclient/metadata.xml3
-rw-r--r--gnustep-libs/sqlclient/sqlclient-1.8.1-r2.ebuild (renamed from gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild)4
10 files changed, 93 insertions, 23 deletions
diff --git a/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild b/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..841a257ae165
--- /dev/null
+++ b/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools gnustep-2
+
+DESCRIPTION="Framework that interfaces Objective-C applications with the D-Bus IPC service"
+HOMEPAGE="https://github.com/gnustep/libs-dbuskit"
+SRC_URI="https://github.com/gnustep/libs-dbuskit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libs-${P}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=sys-apps/dbus-1.2.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-remove_gc.patch )
+
+src_prepare() {
+ default
+
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ # Bug 410697
+ sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
+ -i configure.ac || die "ObjectiveC2 runtime sed failed"
+
+ eautoreconf
+}
diff --git a/gnustep-libs/gsldap/gsldap-0.0.1_pre20070219-r1.ebuild b/gnustep-libs/gsldap/gsldap-0.0.1_pre20070219-r1.ebuild
index 6d2e703ea644..c7ddf6528569 100644
--- a/gnustep-libs/gsldap/gsldap-0.0.1_pre20070219-r1.ebuild
+++ b/gnustep-libs/gsldap/gsldap-0.0.1_pre20070219-r1.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit gnustep-2
DESCRIPTION="GNUstep LDAP library for openldap C libraries"
-HOMEPAGE="http://www.gnustep.org/"
+HOMEPAGE="https://gnustep.github.io/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="net-nds/openldap:="
RDEPEND="${DEPEND}"
diff --git a/gnustep-libs/netclasses/netclasses-1.1.0-r1.ebuild b/gnustep-libs/netclasses/netclasses-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..0aac0c11cc62
--- /dev/null
+++ b/gnustep-libs/netclasses/netclasses-1.1.0-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnustep-2
+
+DESCRIPTION="Asynchronous networking library for GNUstep"
+HOMEPAGE="https://gap.nongnu.org/talksoup/"
+SRC_URI="https://savannah.nongnu.org/download/gap/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}"/${P}-no_rfc.patch )
diff --git a/gnustep-libs/pantomime/pantomime-1.4.0.ebuild b/gnustep-libs/pantomime/pantomime-1.4.0.ebuild
index f5669b6ae8ff..5a56ad643e69 100644
--- a/gnustep-libs/pantomime/pantomime-1.4.0.ebuild
+++ b/gnustep-libs/pantomime/pantomime-1.4.0.ebuild
@@ -2,20 +2,19 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
inherit gnustep-2
MY_P=${P/p/P}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A set of Objective-C classes that model a mail system"
-HOMEPAGE="http://www.nongnu.org/gnustep-nonfsf/gnumail/"
+DESCRIPTION="Set of Objective-C classes that model a mail system"
+HOMEPAGE="https://www.nongnu.org/gnustep-nonfsf/gnumail/"
SRC_URI="mirror://nongnu/gnustep-nonfsf/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
-LICENSE="LGPL-2.1 Elm"
+LICENSE="LGPL-2.1+ Elm"
KEYWORDS="~amd64 ~ppc ~x86"
SLOT="0"
-IUSE=""
DEPEND="dev-libs/openssl:0=
>=gnustep-base/gnustep-base-1.29.0:="
diff --git a/gnustep-libs/performance/performance-0.5.0.ebuild b/gnustep-libs/performance/performance-0.5.0.ebuild
index 5f6bcc8b2665..0f42ec545fcb 100644
--- a/gnustep-libs/performance/performance-0.5.0.ebuild
+++ b/gnustep-libs/performance/performance-0.5.0.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit gnustep-2
MY_P=${P/p/P}
DESCRIPTION="Help improve the performance of GNUstep applications"
-HOMEPAGE="http://wiki.gnustep.org/index.php/Performance"
+HOMEPAGE="https://github.com/gnustep/libs-performance"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="LGPL-3"
+LICENSE="LGPL-3+"
SLOT="0"
-S=${WORKDIR}/${MY_P}
-
src_prepare() {
if ! use doc; then
# Remove doc target
diff --git a/gnustep-libs/renaissance/renaissance-0.9.0-r2.ebuild b/gnustep-libs/renaissance/renaissance-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..1965376d7bb3
--- /dev/null
+++ b/gnustep-libs/renaissance/renaissance-0.9.0-r2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnustep-2
+
+DESCRIPTION="GNUstep Renaissance allows to describe user interfaces XML files"
+HOMEPAGE="https://github.com/gnustep/libs-renaissance"
+SRC_URI="http://www.gnustep.it/Renaissance/Download/${P/r/R}.tar.gz"
+S="${WORKDIR}/${P/r/R}"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.8.1_pre20070522-docpath.patch )
diff --git a/gnustep-libs/sope/sope-5.1.1-r1.ebuild b/gnustep-libs/sope/sope-5.1.1-r1.ebuild
index 08cd6033c79b..fe7d4c7b068b 100644
--- a/gnustep-libs/sope/sope-5.1.1-r1.ebuild
+++ b/gnustep-libs/sope/sope-5.1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
inherit gnustep-2 vcs-snapshot
DESCRIPTION="A set of frameworks forming a complete Web application server environment"
-HOMEPAGE="http://www.sogo.nu/"
+HOMEPAGE="https://www.sogo.nu/"
SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2"
diff --git a/gnustep-libs/sope/sope-5.2.0-r1.ebuild b/gnustep-libs/sope/sope-5.2.0-r1.ebuild
index 08cd6033c79b..fe7d4c7b068b 100644
--- a/gnustep-libs/sope/sope-5.2.0-r1.ebuild
+++ b/gnustep-libs/sope/sope-5.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
inherit gnustep-2 vcs-snapshot
DESCRIPTION="A set of frameworks forming a complete Web application server environment"
-HOMEPAGE="http://www.sogo.nu/"
+HOMEPAGE="https://www.sogo.nu/"
SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2"
diff --git a/gnustep-libs/sqlclient/metadata.xml b/gnustep-libs/sqlclient/metadata.xml
index 825e55f07621..9f6d0808b005 100644
--- a/gnustep-libs/sqlclient/metadata.xml
+++ b/gnustep-libs/sqlclient/metadata.xml
@@ -5,6 +5,9 @@
<email>gnustep@gentoo.org</email>
<name>Gentoo GNUstep Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">gnustep/libs-sqlclient</remote-id>
+ </upstream>
<longdescription>The SQLClient library is designed to provide a simple interface to SQL databases for GNUstep applications. It does not attempt the sort of abstraction provided by the much more sophisticated GDL2 library but rather allows applications to directly execute SQL queries and statements.
SQLClient provides for the Objective-C programmer much the same thing that JDBC provides for the Java programmer (though SQLClient is a bit faster, easier to use, and easier to add new database backends for than JDBC).</longdescription>
diff --git a/gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild b/gnustep-libs/sqlclient/sqlclient-1.8.1-r2.ebuild
index 1e588e7d224a..8f05cc06e501 100644
--- a/gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild
+++ b/gnustep-libs/sqlclient/sqlclient-1.8.1-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit java-pkg-opt-2 gnustep-2
MY_P=${P/sqlc/SQLC}