summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild')
-rw-r--r--gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild b/gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild
new file mode 100644
index 000000000000..d8cb2dbadf48
--- /dev/null
+++ b/gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="EGL External Platform interface"
+HOMEPAGE="https://github.com/NVIDIA/eglexternalplatform"
+SRC_URI="https://github.com/NVIDIA/eglexternalplatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i "/^inc/s@=@=${EPREFIX}@" eglexternalplatform.pc || die
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins eglexternalplatform.pc
+
+ insinto /usr/include/EGL
+ doins interface/*.h
+
+ einstalldocs
+
+ docinto examples
+ dodoc samples/*.c
+}