summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-18.12.0.ebuild110
2 files changed, 0 insertions, 111 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index a7101d4700e7..c28b59977e4a 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1,3 +1,2 @@
DIST cantor-18.08.3.tar.xz 2181020 BLAKE2B 43ce8e60d44d07c1a74219dad3322d23cea89eb9ba199c240d7e95473a79dcaa2a8a2ea08e05a04da00e6bc2fce6cef70b3266c28dd6f9424401bf87b1bfb6a8 SHA512 b6a3bfcc6dce8792fcad9bcaec6b30dfe50ab42b0781a3d33477b2fee1773c20400f4de069176bcf3ae6bfb232a32aa0d5f2e6e9059706f9da6aa65f63a018ec
-DIST cantor-18.12.0.tar.xz 2240772 BLAKE2B 0d6627f8f41b5cfb211e732ad173a1926396f5c59fb4e4b3c5dccf35fbb9d95ecf0e4cdd16bffbae04615dcb933b1e7da050e6fe2655749d6e334d627ffc8f74 SHA512 d1d2daad69bd982da0ae2b82512e0fe3d15a93406c7d24d28e8587514518e4bebe5f807a0c0eafccefbafae06701dd5cff7fe876f863792ff9a98e355d9aae77
DIST cantor-18.12.1.tar.xz 2447272 BLAKE2B 9d49c5751ef6310464a3752516d28eceeeb167c6e2b7b36e2caf9bee56598d17f8428a2ac9a3483e43ebc23f44ec208c6f4ca0e6153aa5eac36aee1d1075b261 SHA512 53128c9868fa0ca0f9f48d828d5232b2316ba3d6808937fbac4f46ddf5797de53fdfc64d91544ef357a60870ead5585531ae600d14d67f724551c365cd62c3cb
diff --git a/kde-apps/cantor/cantor-18.12.0.ebuild b/kde-apps/cantor/cantor-18.12.0.ebuild
deleted file mode 100644
index 4406f96ddb16..000000000000
--- a/kde-apps/cantor/cantor-18.12.0.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_HANDBOOK="forceoptional"
-KDE_TEST="forceoptional"
-PYTHON_COMPAT=( python2_7 )
-# FIXME: PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-inherit kde5 python-r1
-
-DESCRIPTION="Interface for doing mathematics and scientific computing"
-HOMEPAGE="https://www.kde.org/applications/education/cantor https://edu.kde.org/cantor/"
-KEYWORDS="~amd64 ~x86"
-IUSE="+analitza julia lua markdown postscript python qalculate R"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
-# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
-DEPEND="
- $(add_frameworks_dep karchive)
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kcrash)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep knewstuff)
- $(add_frameworks_dep kparts)
- $(add_frameworks_dep kpty)
- $(add_frameworks_dep ktexteditor)
- $(add_frameworks_dep ktextwidgets)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kxmlgui)
- $(add_frameworks_dep syntax-highlighting)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtprintsupport)
- $(add_qt_dep qtsvg)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtxml)
- $(add_qt_dep qtxmlpatterns)
- analitza? ( $(add_kdeapps_dep analitza) )
- julia? ( dev-lang/julia )
- lua? ( dev-lang/luajit:2 )
- markdown? ( >=app-text/discount-2.2.2 )
- qalculate? (
- sci-libs/cln
- sci-libs/libqalculate:=
- )
- postscript? ( app-text/libspectre )
- python? ( ${PYTHON_DEPS} )
- R? ( dev-lang/R )
-"
-RDEPEND="${DEPEND}"
-
-RESTRICT+=" test"
-
-pkg_pretend() {
- kde5_pkg_pretend
-
- if ! has_version sci-mathematics/maxima && ! has_version sci-mathematics/octave && \
- ! use analitza && ! use julia && ! use lua && ! use python && ! use qalculate && ! use R; then
- elog "You have decided to build ${PN} with no backend."
- elog "To have this application functional, please enable one of the backends via USE flag:"
- elog " analitza, lua, python, qalculate, R"
- elog "Alternatively, install one of these:"
- elog " # emerge sci-mathematics/maxima (bug #619534)"
- elog " # emerge sci-mathematics/octave"
- elog "Experimental available USE flag:"
- elog " julia (not stable, bug #613576)"
- elog
- fi
-
- if ! has_version virtual/latex-base; then
- elog "For LaTeX support:"
- elog " # emerge virtual/latex-base"
- fi
-}
-
-pkg_setup() {
- use python && python_setup
- kde5_pkg_setup
-}
-
-src_prepare() {
- kde5_src_prepare
-
- # FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
- sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
- -i src/backends/CMakeLists.txt || die
-}
-
-src_configure() {
- use julia && addpredict /proc/self/mem # bug 602894
-
- local mycmakeargs=(
- $(cmake-utils_use_find_package analitza Analitza5)
- $(cmake-utils_use_find_package julia Julia)
- $(cmake-utils_use_find_package lua LuaJIT)
- $(cmake-utils_use_find_package markdown Discount)
- $(cmake-utils_use_find_package postscript LibSpectre)
- $(cmake-utils_use_find_package python PythonLibs)
- $(cmake-utils_use_find_package qalculate Qalculate)
- $(cmake-utils_use_find_package R R)
- )
- kde5_src_configure
-}