summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.3.ebuild')
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.3.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.3.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.3.ebuild
deleted file mode 100644
index b93a5e4ac2c0..000000000000
--- a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-KDE_ORG_NAME="dolphin-plugins"
-ECM_HANDBOOK="false"
-MY_PLUGIN_NAME="git"
-PVCUT=$(ver_cut 1-3)
-KFMIN=5.60.0
-QTMIN=5.12.3
-inherit ecm kde.org
-
-DESCRIPTION="Dolphin plugin for Git integration"
-LICENSE="GPL-2" # TODO: CHECK
-SLOT="5"
-KEYWORDS="amd64 arm64 x86"
-IUSE=""
-
-DEPEND="
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-apps/dolphin-${PVCUT}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
-"
-RDEPEND="${DEPEND}
- !kde-apps/dolphin-plugins:5
- dev-vcs/git
-"
-
-src_prepare() {
- ecm_src_prepare
- # kxmlgui, qtnetwork only required by dropbox
- ecm_punt_bogus_dep Qt5 Network
- ecm_punt_bogus_dep KF5 XmlGui
- # delete non-${PN} translations
- if [[ ${KDE_BUILD_TYPE} = release ]]; then
- find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_${MY_PLUGIN_NAME}=ON
- -DBUILD_bazaar=OFF
- -DBUILD_dropbox=OFF
- -DBUILD_hg=OFF
- -DBUILD_svn=OFF
- )
- ecm_src_configure
-}