summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kmail-account-wizard')
-rw-r--r--kde-apps/kmail-account-wizard/Manifest1
-rw-r--r--kde-apps/kmail-account-wizard/files/kmail-account-wizard-20.04.3-CVE-2020-15954.patch81
-rw-r--r--kde-apps/kmail-account-wizard/kmail-account-wizard-20.04.3-r1.ebuild55
3 files changed, 0 insertions, 137 deletions
diff --git a/kde-apps/kmail-account-wizard/Manifest b/kde-apps/kmail-account-wizard/Manifest
index c346f956746f..c3bc0d09f109 100644
--- a/kde-apps/kmail-account-wizard/Manifest
+++ b/kde-apps/kmail-account-wizard/Manifest
@@ -1,2 +1 @@
-DIST kmail-account-wizard-20.04.3.tar.xz 158132 BLAKE2B 237e1d9535c1dde19ad21ceed08177da0d98cc773a96785afaa14a8e780573f30ad4ab9ba946314ce440093923acc3dbc91406c598f02b017556a74d9fe8df52 SHA512 71a305dcf51fe20d700c181f0a13981bae243e2a3d9080e58cc4ec24a1adc625f500936656b732fd419cfbfef9258af1ace45789c7756687a22788fc5d9da296
DIST kmail-account-wizard-20.08.3.tar.xz 161832 BLAKE2B 01e23924f4728e8a24a83a17a49ef556f125fadeae5da01df57eb0bc3446d387cded535946b33051fc814be06ae46ab240c811c07cad2c238efc71f789bbc38b SHA512 5526e55c8ec49473f41245cf5ebf18997ff4db20637d92fa6db8e20f353a95f255ec69ae03b6eeb9b0ff09180e78260af7392806f931f10bc105dc2dd5f102e4
diff --git a/kde-apps/kmail-account-wizard/files/kmail-account-wizard-20.04.3-CVE-2020-15954.patch b/kde-apps/kmail-account-wizard/files/kmail-account-wizard-20.04.3-CVE-2020-15954.patch
deleted file mode 100644
index a1c63e3a3a1d..000000000000
--- a/kde-apps/kmail-account-wizard/files/kmail-account-wizard-20.04.3-CVE-2020-15954.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From a64d80e523edce7d3d59c26834973418fae042f6 Mon Sep 17 00:00:00 2001
-From: Laurent Montel <montel@kde.org>
-Date: Tue, 28 Jul 2020 13:52:19 +0200
-Subject: [PATCH] Show info about encryption/authentication settings
-
-CCBUG: 423426
----
- src/transport.cpp | 18 +++++++++++++++---
- src/transport.h | 2 ++
- 2 files changed, 17 insertions(+), 3 deletions(-)
-
-diff --git a/src/transport.cpp b/src/transport.cpp
-index 567df31..26344ef 100644
---- a/src/transport.cpp
-+++ b/src/transport.cpp
-@@ -53,14 +53,16 @@ static const StringValueTable<MailTransport::Transport::EnumAuthenticationType>
- static const int authenticationTypeEnumSize = sizeof(authenticationTypeEnum) / sizeof(*authenticationTypeEnum);
-
- template<typename T>
--static typename T::value_type stringToValue(const T *table, const int tableSize, const QString &string)
-+static typename T::value_type stringToValue(const T *table, const int tableSize, const QString &string, bool &valid)
- {
- const QString ref = string.toLower();
- for (int i = 0; i < tableSize; ++i) {
- if (ref == QLatin1String(table[i].name)) {
-+ valid = true;
- return table[i].value;
- }
- }
-+ valid = false;
- return table[0].value; // TODO: error handling
- }
-
-@@ -98,6 +100,7 @@ void Transport::create()
- mt->setAuthenticationType(m_auth);
- m_transportId = mt->id();
- mt->save();
-+ Q_EMIT info(i18n("Mail transport uses '%1' encryption and '%2' authentication.", m_encrStr, m_authStr));
- MailTransport::TransportManager::self()->addTransport(mt);
- MailTransport::TransportManager::self()->setDefaultTransport(mt->id());
- if (m_editMode) {
-@@ -154,12 +157,21 @@ void Transport::setPassword(const QString &password)
-
- void Transport::setEncryption(const QString &encryption)
- {
-- m_encr = stringToValue(encryptionEnum, encryptionEnumSize, encryption);
-+ bool valid;
-+ m_encr = stringToValue(encryptionEnum, encryptionEnumSize, encryption, valid);
-+ if (valid) {
-+ m_encrStr = encryption;
-+ }
- }
-
- void Transport::setAuthenticationType(const QString &authType)
- {
-- m_auth = stringToValue(authenticationTypeEnum, authenticationTypeEnumSize, authType);
-+ bool valid;
-+ m_auth = stringToValue(authenticationTypeEnum, authenticationTypeEnumSize, authType, valid);
-+ if (valid) {
-+ m_authStr = authType;
-+ }
-+
- }
-
- int Transport::transportId() const
-diff --git a/src/transport.h b/src/transport.h
-index 3773b04..6415bf9 100644
---- a/src/transport.h
-+++ b/src/transport.h
-@@ -53,6 +53,8 @@ private:
- QString m_password;
- MailTransport::Transport::EnumEncryption::type m_encr;
- MailTransport::Transport::EnumAuthenticationType::type m_auth;
-+ QString m_encrStr;
-+ QString m_authStr;
-
- bool m_editMode;
- };
---
-GitLab
-
diff --git a/kde-apps/kmail-account-wizard/kmail-account-wizard-20.04.3-r1.ebuild b/kde-apps/kmail-account-wizard/kmail-account-wizard-20.04.3-r1.ebuild
deleted file mode 100644
index 3ba6a85d5258..000000000000
--- a/kde-apps/kmail-account-wizard/kmail-account-wizard-20.04.3-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
-ECM_TEST="forceoptional"
-PVCUT=$(ver_cut 1-3)
-KFMIN=5.70.0
-QTMIN=5.14.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="Assistant for KMail accounts configuration"
-HOMEPAGE+=" https://userbase.kde.org/KMail/Account_Wizard"
-
-LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
-SLOT="5"
-KEYWORDS="amd64 arm64 x86"
-IUSE=""
-
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-apps/akonadi-${PVCUT}:5
- >=kde-apps/kidentitymanagement-${PVCUT}:5
- >=kde-apps/kldap-${PVCUT}:5
- >=kde-apps/kmailtransport-${PVCUT}:5
- >=kde-apps/libkdepim-${PVCUT}:5
- >=kde-apps/libkleo-${PVCUT}:5
- >=kde-apps/pimcommon-${PVCUT}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kcodecs-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kitemviews-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/knotifyconfig-${KFMIN}:5
- >=kde-frameworks/kross-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktexteditor-${KFMIN}:5
- >=kde-frameworks/kwallet-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-CVE-2020-15954.patch" )