summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/ktimetracker')
-rw-r--r--kde-apps/ktimetracker/files/ktimetracker-4.4.2017.04-gcc-6.3.patch11
-rw-r--r--kde-apps/ktimetracker/ktimetracker-4.4.2017.04.ebuild2
2 files changed, 13 insertions, 0 deletions
diff --git a/kde-apps/ktimetracker/files/ktimetracker-4.4.2017.04-gcc-6.3.patch b/kde-apps/ktimetracker/files/ktimetracker-4.4.2017.04-gcc-6.3.patch
new file mode 100644
index 000000000000..070514e15616
--- /dev/null
+++ b/kde-apps/ktimetracker/files/ktimetracker-4.4.2017.04-gcc-6.3.patch
@@ -0,0 +1,11 @@
+--- a/ktimetracker/taskview.cpp
++++ b/ktimetracker/taskview.cpp
+@@ -840,7 +840,7 @@
+
+ void TaskView::newTask( const QString &caption, Task *parent )
+ {
+- EditTaskDialog *dialog = new EditTaskDialog( this, caption, false );
++ EditTaskDialog *dialog = new EditTaskDialog( this, caption, NULL );
+ long total, totalDiff, session, sessionDiff;
+ DesktopList desktopList;
+
diff --git a/kde-apps/ktimetracker/ktimetracker-4.4.2017.04.ebuild b/kde-apps/ktimetracker/ktimetracker-4.4.2017.04.ebuild
index 5a386c88f2a8..c27e63e89250 100644
--- a/kde-apps/ktimetracker/ktimetracker-4.4.2017.04.ebuild
+++ b/kde-apps/ktimetracker/ktimetracker-4.4.2017.04.ebuild
@@ -30,6 +30,8 @@ KMEXTRACTONLY="
KMLOADLIBS="libkdepim"
+PATCHES=( "${FILESDIR}/${P}-gcc-6.3.patch" )
+
src_unpack() {
if use kontact; then
KMEXTRA="${KMEXTRA} kontact/plugins/ktimetracker"