summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/libkgeomap/libkgeomap-19.12.0.ebuild')
-rw-r--r--kde-apps/libkgeomap/libkgeomap-19.12.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-apps/libkgeomap/libkgeomap-19.12.0.ebuild b/kde-apps/libkgeomap/libkgeomap-19.12.0.ebuild
new file mode 100644
index 000000000000..060a3a91700b
--- /dev/null
+++ b/kde-apps/libkgeomap/libkgeomap-19.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Wrapper library for world map components as marble, openstreetmap and googlemap"
+HOMEPAGE="https://www.digikam.org/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-apps/marble-${PVCUT}:5=[kde]
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwebkit-5.212.0_pre20180120:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use test && local mycmakeargs=( -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=true )
+
+ ecm_src_configure
+}