summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/solid-runtime/solid-runtime-16.04.3.ebuild')
-rw-r--r--kde-apps/solid-runtime/solid-runtime-16.04.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-apps/solid-runtime/solid-runtime-16.04.3.ebuild b/kde-apps/solid-runtime/solid-runtime-16.04.3.ebuild
new file mode 100644
index 000000000000..409b91d27a03
--- /dev/null
+++ b/kde-apps/solid-runtime/solid-runtime-16.04.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KMNAME="kde-runtime"
+KMNOMODULE=true
+inherit kde4-meta
+
+DESCRIPTION="KDE SC solid runtime modules (autoeject, automounter and others)"
+HOMEPAGE="https://solid.kde.org"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug bluetooth networkmanager"
+
+KMEXTRA="
+ solid-device-automounter/
+ solid-hardware/
+ solid-networkstatus/
+ solidautoeject/
+ soliduiserver/
+"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ bluetooth? ( || ( net-wireless/bluedevil kde-plasma/bluedevil ) )
+ networkmanager? ( || ( kde-misc/plasma-nm kde-misc/networkmanagement kde-plasma/plasma-nm ) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.14.3-networkmanager-1.0.6.patch" )