summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/frameworkintegration/frameworkintegration-5.23.0.ebuild')
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.23.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.23.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.23.0.ebuild
new file mode 100644
index 000000000000..8ae8b6876d49
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.23.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}