summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kcodecs')
-rw-r--r--kde-frameworks/kcodecs/files/kcodecs-5.54.0-CVE-2013-0779.patch25
-rw-r--r--kde-frameworks/kcodecs/kcodecs-5.54.0-r1.ebuild18
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kcodecs/files/kcodecs-5.54.0-CVE-2013-0779.patch b/kde-frameworks/kcodecs/files/kcodecs-5.54.0-CVE-2013-0779.patch
new file mode 100644
index 000000000000..d5f0092ea255
--- /dev/null
+++ b/kde-frameworks/kcodecs/files/kcodecs-5.54.0-CVE-2013-0779.patch
@@ -0,0 +1,25 @@
+From 9d3fdbed7bf161d19a9440f2d33ada1e93082332 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Wed, 6 Feb 2019 20:04:01 +0100
+Subject: Fix for CVE-2013-0779
+
+Only six years late ^_^
+---
+ src/probers/nsEscSM.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/probers/nsEscSM.cpp b/src/probers/nsEscSM.cpp
+index 6e3ea74..ec134ed 100644
+--- a/src/probers/nsEscSM.cpp
++++ b/src/probers/nsEscSM.cpp
+@@ -183,7 +183,7 @@ static const unsigned int ISO2022JP_st [ 9] = {
+ PCK4BITS(eError, eError, eError, eError, eItsMe, eError, eStart, eStart) //40-47
+ };
+
+-static const unsigned int ISO2022JPCharLenTable[] = {0, 0, 0, 0, 0, 0, 0, 0};
++static const unsigned int ISO2022JPCharLenTable[] = {0, 0, 0, 0, 0, 0, 0, 0, 0, 0};
+
+ const SMModel ISO2022JPSMModel = {
+ {eIdxSft4bits, eSftMsk4bits, eBitSft4bits, eUnitMsk4bits, ISO2022JP_cls },
+--
+cgit v1.1
diff --git a/kde-frameworks/kcodecs/kcodecs-5.54.0-r1.ebuild b/kde-frameworks/kcodecs/kcodecs-5.54.0-r1.ebuild
new file mode 100644
index 000000000000..32f8a3e266a5
--- /dev/null
+++ b/kde-frameworks/kcodecs/kcodecs-5.54.0-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Framework for manipulating strings using various encodings"
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-util/gperf
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+PATCHES=( "${FILESDIR}/${P}-CVE-2013-0779.patch" )