summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.12.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.12.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.12.0.ebuild b/kde-frameworks/kcrash/kcrash-5.12.0.ebuild
new file mode 100644
index 000000000000..8cf2e088f68f
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls X"
+
+# requires running kde environment
+RESTRICT="test"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ dev-qt/qtgui:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+ test? ( dev-qt/qtwidgets:5 )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}