summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kcrash')
-rw-r--r--kde-frameworks/kcrash/Manifest1
-rw-r--r--kde-frameworks/kcrash/kcrash-5.48.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/Manifest b/kde-frameworks/kcrash/Manifest
index 5136e80f926f..866248abb0ab 100644
--- a/kde-frameworks/kcrash/Manifest
+++ b/kde-frameworks/kcrash/Manifest
@@ -1,2 +1,3 @@
DIST kcrash-5.46.0.tar.xz 21876 BLAKE2B 31c0a4ebf744ce59f866527c967dfe1784e8b95785f805b1d782eea8bbedc72ffcd13ac6eec135abaa1c5b163dc19833f554917d5f35681ee055ad9e268b1cf6 SHA512 b286e3d396d31c52deffd250d064795166a9ad6b19de63bca3eba1c37d8919bc0e31e2238c30f901403cac19dc956fb6515c8ee5a1a73287a14b79d674048b39
DIST kcrash-5.47.0.tar.xz 21876 BLAKE2B a12986f8913ef6c441ebb3659f8231a04fa549a5d5b26a2dc795fa0f8fde1af3dc2b68ce974dde64f78b53eae4327710ec662e3157926f9930c544d0245b7255 SHA512 981052624090b05db21683895ac8517f2530c7393bc206d2932e19b5293c138315d8b53fdbb10fb5ddf085a5d488d909c893c25046b34249eb317355d1388372
+DIST kcrash-5.48.0.tar.xz 21916 BLAKE2B 034241c6fb7c52694dbe45b0f3a201dcea6b19ea2bd91d79a35da0e763712f91d337aaa00be1063dea6acdf83bb6f91f8968e7d60720e4da9d6557c63419b3b3 SHA512 3c0abab1e52d51c6f92ff3f5a808a73a82f2ecb7a64d00ec652521c1fe29ad3f4273f34c73c958481e339d7000bd03927d4bb2536e99cbde5e050d26028ca2cb
diff --git a/kde-frameworks/kcrash/kcrash-5.48.0.ebuild b/kde-frameworks/kcrash/kcrash-5.48.0.ebuild
new file mode 100644
index 000000000000..627296fb3f0e
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.48.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ nls? ( $(add_qt_dep linguist-tools) )
+ test? ( $(add_qt_dep qtwidgets) )
+"