summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/ki18n')
-rw-r--r--kde-frameworks/ki18n/files/ki18n-5.45.0-fix-build-pofiles.patch38
-rw-r--r--kde-frameworks/ki18n/ki18n-5.45.0-r2.ebuild40
2 files changed, 78 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/files/ki18n-5.45.0-fix-build-pofiles.patch b/kde-frameworks/ki18n/files/ki18n-5.45.0-fix-build-pofiles.patch
new file mode 100644
index 000000000000..055a4c24db98
--- /dev/null
+++ b/kde-frameworks/ki18n/files/ki18n-5.45.0-fix-build-pofiles.patch
@@ -0,0 +1,38 @@
+From 9c32bdab29b345976eee3b9c1c4bebd76cdcdde2 Mon Sep 17 00:00:00 2001
+From: Aleix Pol <aleixpol@kde.org>
+Date: Sun, 15 Apr 2018 01:39:58 +0200
+Subject: Don't need to run previous iterations commands again
+
+Summary: BUG: 393141
+
+Test Plan:
+Tested building plasma-workspace, it was clearly faster (although it
+would have finished eventually)
+
+Reviewers: #frameworks, arojas, sitter
+
+Reviewed By: sitter
+
+Subscribers: sitter, heikobecker
+
+Tags: #frameworks
+
+Differential Revision: https://phabricator.kde.org/D12216
+---
+ cmake/build-pofiles.cmake | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cmake/build-pofiles.cmake b/cmake/build-pofiles.cmake
+index d0991ad..b39be31 100644
+--- a/cmake/build-pofiles.cmake
++++ b/cmake/build-pofiles.cmake
+@@ -62,6 +62,7 @@ foreach(pofile IN LISTS pofiles)
+ if(i EQUAL ${numberOfProcesses})
+ _processCommands()
+ set(i 0)
++ set(commands)
+ endif()
+ endforeach()
+
+--
+cgit v0.11.2
diff --git a/kde-frameworks/ki18n/ki18n-5.45.0-r2.ebuild b/kde-frameworks/ki18n/ki18n-5.45.0-r2.ebuild
new file mode 100644
index 000000000000..f419eb730153
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.45.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit kde5 python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_qt_dep qtscript)
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdeclarative)
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-build-pofiles.patch" )
+
+pkg_setup() {
+ kde5_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ kde5_src_configure
+}