summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kimageformats/kimageformats-5.15.0.ebuild')
-rw-r--r--kde-frameworks/kimageformats/kimageformats-5.15.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kimageformats/kimageformats-5.15.0.ebuild b/kde-frameworks/kimageformats/kimageformats-5.15.0.ebuild
new file mode 100644
index 000000000000..e5e05fe830e7
--- /dev/null
+++ b/kde-frameworks/kimageformats/kimageformats-5.15.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing additional format plugins for Qt's image I/O system"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="eps openexr"
+
+RDEPEND="
+ dev-qt/qtgui:5
+ eps? ( dev-qt/qtprintsupport:5 )
+ openexr? (
+ media-libs/ilmbase:=
+ media-libs/openexr:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( src/imageformats/AUTHORS )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package eps Qt5PrintSupport)
+ $(cmake-utils_use_find_package openexr OpenEXR)
+ )
+
+ kde5_src_configure
+}