summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/knotifications/knotifications-5.35.0.ebuild')
-rw-r--r--kde-frameworks/knotifications/knotifications-5.35.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/knotifications/knotifications-5.35.0.ebuild b/kde-frameworks/knotifications/knotifications-5.35.0.ebuild
new file mode 100644
index 000000000000..4eb54a810f3f
--- /dev/null
+++ b/kde-frameworks/knotifications/knotifications-5.35.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework for notifying the user of an event"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus nls speech X"
+
+# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ media-libs/phonon[qt5]
+ dbus? ( dev-libs/libdbusmenu-qt[qt5] )
+ speech? ( $(add_qt_dep qtspeech) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package dbus dbusmenu-qt5)
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}