summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/knotifications')
-rw-r--r--kde-frameworks/knotifications/Manifest1
-rw-r--r--kde-frameworks/knotifications/files/knotifications-5.34.0-no-block-notification.patch101
-rw-r--r--kde-frameworks/knotifications/knotifications-5.34.0-r1.ebuild47
-rw-r--r--kde-frameworks/knotifications/knotifications-5.34.0.ebuild45
4 files changed, 0 insertions, 194 deletions
diff --git a/kde-frameworks/knotifications/Manifest b/kde-frameworks/knotifications/Manifest
index 158aa7660d21..fce4f42db570 100644
--- a/kde-frameworks/knotifications/Manifest
+++ b/kde-frameworks/knotifications/Manifest
@@ -1,3 +1,2 @@
-DIST knotifications-5.34.0.tar.xz 99748 SHA256 295e9325bc6ffe8c2aff1922fc7633b3e6f9d1fa90cf377635f9170bd487e58b SHA512 11c62c1fcd58ec4c26668dbe0900b7c4cbea8f515d812d4b6a9617d2ec0b1153049f098a2f7f80de117eebed5c9809a16787ae6119aaee7b12f160ceec5dd553 WHIRLPOOL 98c26ec7f2f2c7ba27317e22abb55e79a5b04395f6ce277c3a492825ea23030b572bb5aaab03dc5ea49607aeb3017048ad3b357f4514b3f8f54a02628263f335
DIST knotifications-5.37.0.tar.xz 100004 SHA256 66cdfddaa31f773a538d429026d0117e60f8a0a7f2a90c861f95d84395347b3f SHA512 3b08faf67d705233e98ff5e6cacdb6983134942f1ea5bb8cac43ecfe7b15aac987702cf635dd8dc3e45047e5069bb3fcd39c9745ac4bf414bb33f69336013644 WHIRLPOOL ec6c1ad4da2c45d0dc058d2b1c5c53679c68a1822b76085a71647f3386eede2ab86b9c8f38bc26b2f7b9a793de0c8508c5b22d539788e0043c37fd9212e01102
DIST knotifications-5.38.0.tar.xz 99904 SHA256 ed7d33414840c8b25ce0f7fc446516bd85458b4e349825da026eb511a1d875cb SHA512 47d3268edd3162f48973e3ca0586df73ec3115b100c866e014e8dbf4b36f5102d85d97d722e849641415e2f91e7e1f2e5976b42e7a34ae95ba8ecf88e8ec0672 WHIRLPOOL 9f332d335cdae3af9ab4927ff26716b810c848c6215852cff0ed16909743654bb8fcca39ca4939ede2ec6ef16aecb6143b21a4c5b4dc0f61bb2134b63df6578b
diff --git a/kde-frameworks/knotifications/files/knotifications-5.34.0-no-block-notification.patch b/kde-frameworks/knotifications/files/knotifications-5.34.0-no-block-notification.patch
deleted file mode 100644
index 2d1ae95af5fb..000000000000
--- a/kde-frameworks/knotifications/files/knotifications-5.34.0-no-block-notification.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From 1c97e1d9741fd15962474f47932dd09728dae76b Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Fri, 28 Jul 2017 13:04:50 +0100
-Subject: [PATCH] Don't block starting notification service
-
-Summary:
-We don't need to manually start the DBus service.
-It blocks the calling app, and dbusServiceExists means that we will
-always end up going the DBus route over a popup anyway, so it won't
-do anything useful.
-
-The service (in the plasma case plasma-wait-for-name) will be started
-automatically when we actually send the notification.
-
-Also fix d-dbusServiceExists being cleared to false when the first
-service owner exits.
-
-BUG: 382444
-
-Subscribers: #frameworks
-
-Tags: #frameworks
-
-Differential Revision: https://phabricator.kde.org/D6963
----
- src/notifybypopup.cpp | 28 +++++++++++-----------------
- 1 file changed, 11 insertions(+), 17 deletions(-)
-
-diff --git a/src/notifybypopup.cpp b/src/notifybypopup.cpp
-index 735d52b..4f244e1 100644
---- a/src/notifybypopup.cpp
-+++ b/src/notifybypopup.cpp
-@@ -109,6 +109,9 @@ public:
- * Specifies if DBus Notifications interface exists on session bus
- */
- bool dbusServiceExists;
-+
-+ bool dbusServiceActivatable;
-+
- /**
- * DBus notification daemon capabilities cache.
- * Do not use this variable. Use #popupServerCapabilities() instead.
-@@ -161,6 +164,7 @@ NotifyByPopup::NotifyByPopup(QObject *parent)
- {
- d->animationTimer = 0;
- d->dbusServiceExists = false;
-+ d->dbusServiceActivatable = false;
- d->dbusServiceCapCacheDirty = true;
- d->nextPosition = -1;
-
-@@ -180,32 +184,20 @@ NotifyByPopup::NotifyByPopup(QObject *parent)
- connect(watcher, SIGNAL(serviceOwnerChanged(QString,QString,QString)),
- SLOT(onServiceOwnerChanged(QString,QString,QString)));
-
-+#ifndef Q_WS_WIN
- if (!d->dbusServiceExists) {
-- bool startfdo = false;
--#ifdef Q_WS_WIN
-- startfdo = true;
--#else
- QDBusMessage message = QDBusMessage::createMethodCall(QStringLiteral("org.freedesktop.DBus"),
- QStringLiteral("/org/freedesktop/DBus"),
- QStringLiteral("org.freedesktop.DBus"),
- QStringLiteral("ListActivatableNames"));
--
-- // FIXME - this should be async
- QDBusReply<QStringList> reply = QDBusConnection::sessionBus().call(message);
- if (reply.isValid() && reply.value().contains(dbusServiceName)) {
-- startfdo = true;
-- // We need to set d->dbusServiceExists to true because dbus might be too slow
-- // starting the service and the first call to NotifyByPopup::notify
-- // might not have had the service up, by setting this to true we
-- // guarantee it will still go through dbus and dbus will do the correct
-- // thing and wait for the service to go up
-+ d->dbusServiceActivatable = true;
-+ //if the service is activatable, we can assume it exists even if it is not currently running
- d->dbusServiceExists = true;
- }
--#endif
-- if (startfdo) {
-- QDBusConnection::sessionBus().interface()->startService(dbusServiceName);
-- }
- }
-+#endif
- }
-
-
-@@ -439,7 +431,9 @@ void NotifyByPopup::onServiceOwnerChanged(const QString &serviceName, const QStr
-
- if (newOwner.isEmpty()) {
- d->notificationQueue.clear();
-- d->dbusServiceExists = false;
-+ if (!d->dbusServiceActivatable) {
-+ d->dbusServiceExists = false;
-+ }
- } else if (oldOwner.isEmpty()) {
- d->dbusServiceExists = true;
-
---
-2.13.5
-
diff --git a/kde-frameworks/knotifications/knotifications-5.34.0-r1.ebuild b/kde-frameworks/knotifications/knotifications-5.34.0-r1.ebuild
deleted file mode 100644
index ce529c31487b..000000000000
--- a/kde-frameworks/knotifications/knotifications-5.34.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="false"
-inherit kde5
-
-DESCRIPTION="Framework for notifying the user of an event"
-LICENSE="LGPL-2.1+"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="dbus nls speech X"
-
-# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
-RDEPEND="
- $(add_frameworks_dep kcodecs)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui '' '' '5=')
- $(add_qt_dep qtwidgets)
- media-libs/phonon[qt5(+)]
- dbus? ( dev-libs/libdbusmenu-qt[qt5(+)] )
- speech? ( $(add_qt_dep qtspeech) )
- X? (
- $(add_qt_dep qtx11extras)
- x11-libs/libX11
- x11-libs/libXtst
- )
-"
-DEPEND="${RDEPEND}
- nls? ( $(add_qt_dep linguist-tools) )
- X? ( x11-proto/xproto )
-"
-
-PATCHES=( "${FILESDIR}/${P}-no-block-notification.patch" )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package dbus dbusmenu-qt5)
- $(cmake-utils_use_find_package speech Qt5TextToSpeech)
- $(cmake-utils_use_find_package X X11)
- )
-
- kde5_src_configure
-}
diff --git a/kde-frameworks/knotifications/knotifications-5.34.0.ebuild b/kde-frameworks/knotifications/knotifications-5.34.0.ebuild
deleted file mode 100644
index 35125e938114..000000000000
--- a/kde-frameworks/knotifications/knotifications-5.34.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="false"
-inherit kde5
-
-DESCRIPTION="Framework for notifying the user of an event"
-LICENSE="LGPL-2.1+"
-KEYWORDS="amd64 ~arm x86"
-IUSE="dbus nls speech X"
-
-# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
-RDEPEND="
- $(add_frameworks_dep kcodecs)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui '' '' '5=')
- $(add_qt_dep qtwidgets)
- media-libs/phonon[qt5(+)]
- dbus? ( dev-libs/libdbusmenu-qt[qt5(+)] )
- speech? ( $(add_qt_dep qtspeech) )
- X? (
- $(add_qt_dep qtx11extras)
- x11-libs/libX11
- x11-libs/libXtst
- )
-"
-DEPEND="${RDEPEND}
- nls? ( $(add_qt_dep linguist-tools) )
- X? ( x11-proto/xproto )
-"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package dbus dbusmenu-qt5)
- $(cmake-utils_use_find_package speech Qt5TextToSpeech)
- $(cmake-utils_use_find_package X X11)
- )
-
- kde5_src_configure
-}