summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/knotifyconfig/knotifyconfig-5.100.0.ebuild')
-rw-r--r--kde-frameworks/knotifyconfig/knotifyconfig-5.100.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/knotifyconfig/knotifyconfig-5.100.0.ebuild b/kde-frameworks/knotifyconfig/knotifyconfig-5.100.0.ebuild
new file mode 100644
index 000000000000..a1f0b20c7345
--- /dev/null
+++ b/kde-frameworks/knotifyconfig/knotifyconfig-5.100.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for configuring desktop notifications"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="phonon"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ !phonon? ( media-libs/libcanberra )
+ phonon? ( >=media-libs/phonon-4.11.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !phonon Canberra)
+ )
+ ecm_src_configure
+}