summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/knotifyconfig/knotifyconfig-5.68.0.ebuild')
-rw-r--r--kde-frameworks/knotifyconfig/knotifyconfig-5.68.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-frameworks/knotifyconfig/knotifyconfig-5.68.0.ebuild b/kde-frameworks/knotifyconfig/knotifyconfig-5.68.0.ebuild
new file mode 100644
index 000000000000..1c0c94391fed
--- /dev/null
+++ b/kde-frameworks/knotifyconfig/knotifyconfig-5.68.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework for configuring desktop notifications"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="phonon"
+
+DEPEND="
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ phonon? ( media-libs/phonon[qt5(+)] )
+"
+RDEPEND="${DEPEND}"