summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kparts/kparts-5.64.0.ebuild')
-rw-r--r--kde-frameworks/kparts/kparts-5.64.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kparts/kparts-5.64.0.ebuild b/kde-frameworks/kparts/kparts-5.64.0.ebuild
new file mode 100644
index 000000000000..530fb425bf75
--- /dev/null
+++ b/kde-frameworks/kparts/kparts-5.64.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework providing elaborate user-interface components"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=kde-frameworks/kconfig-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${PVCUT}:5
+ >=kde-frameworks/ki18n-${PVCUT}:5
+ >=kde-frameworks/kiconthemes-${PVCUT}:5
+ >=kde-frameworks/kio-${PVCUT}:5
+ >=kde-frameworks/kjobwidgets-${PVCUT}:5
+ >=kde-frameworks/kservice-${PVCUT}:5
+ >=kde-frameworks/kwidgetsaddons-${PVCUT}:5
+ >=kde-frameworks/kxmlgui-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+"
+DEPEND="${RDEPEND}
+ >=kde-frameworks/ktextwidgets-${PVCUT}:5
+"