summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kpty/kpty-5.29.0.ebuild')
-rw-r--r--kde-frameworks/kpty/kpty-5.29.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/kpty/kpty-5.29.0.ebuild b/kde-frameworks/kpty/kpty-5.29.0.ebuild
new file mode 100644
index 000000000000..7c64bc4ee928
--- /dev/null
+++ b/kde-frameworks/kpty/kpty-5.29.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for pseudo terminal devices and running child processes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ sys-libs/libutempter
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUTEMPTER_EXECUTABLE="${EPREFIX}/usr/sbin/utempter"
+ )
+
+ kde5_src_configure
+}