summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kwayland/kwayland-5.35.0.ebuild')
-rw-r--r--kde-frameworks/kwayland/kwayland-5.35.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/kwayland/kwayland-5.35.0.ebuild b/kde-frameworks/kwayland/kwayland-5.35.0.ebuild
new file mode 100644
index 000000000000..eb0eef8fcdde
--- /dev/null
+++ b/kde-frameworks/kwayland/kwayland-5.35.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/kwayland"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui 'egl')
+ >=dev-libs/wayland-1.7.0
+ media-libs/mesa[egl]
+"
+RDEPEND="${DEPEND}
+ $(add_qt_dep qtwayland 'egl')
+"
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"