summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.36.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.36.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.36.0.ebuild b/kde-frameworks/sonnet/sonnet-5.36.0.ebuild
new file mode 100644
index 000000000000..63fe8c9580e4
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.36.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}