summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kdirstat/kdirstat-3.1.3.ebuild')
-rw-r--r--kde-misc/kdirstat/kdirstat-3.1.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-misc/kdirstat/kdirstat-3.1.3.ebuild b/kde-misc/kdirstat/kdirstat-3.1.3.ebuild
new file mode 100644
index 000000000000..ef6184cdc45f
--- /dev/null
+++ b/kde-misc/kdirstat/kdirstat-3.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="GUI equivalent to the du command based on KDE Frameworks"
+HOMEPAGE="https://bitbucket.org/jeromerobert/k4dirstat/"
+SRC_URI="https://bitbucket.org/jeromerobert/k4dirstat/get/k4dirstat-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ sys-libs/zlib
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/kdirstat:4
+"
+
+src_unpack() {
+ # tarball contains git revision hash, which we don't want in the ebuild.
+ default
+ mv "${WORKDIR}"/*k4dirstat-* "${S}" || die
+}