summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.14.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 0bc8a1b1741c..11842abbdee1 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,3 +1,4 @@
DIST ksshaskpass-5.12.7.tar.xz 21332 BLAKE2B bef0308071942b1c964ddb6f53574e46ecf04018636d6aa34c42d7cdc9f7cc51110678746d5debdc4dfe8c2463c3369dc91fd7c3446be897c1ff670ad88a8d9e SHA512 0c613b5263721a510844b24f4311d906f229acdbb72967902973f995b88973f68f13fd098bf702d1281023f17eafb87de388589062da1b58923479e6fe831a7a
DIST ksshaskpass-5.13.5.tar.xz 21408 BLAKE2B f69798427ca5e4681543580158fc0ded5c4c3d352e31476cbc7832e99844cd30d8134785c460900724fdbd922ef526974dfc28d76ef89369ac309bcbf495e334 SHA512 88712a268710bac6c60bb111d79bf52f5b34e0a7e0f27ea1affb32bc1a18925998a5040e1b96907e4e1648304706ca2c3c2815d98b7807d972fbf8f57f285e96
DIST ksshaskpass-5.14.2.tar.xz 21348 BLAKE2B c47fb45efad17eb53a2e3f85d7a01d78e473748b42083831c2905ec09ee4dcbc6785bf624f05b1e24b694c8a12855f1289803c271a54d7b8113f8fd2506273c8 SHA512 88926caa8b476af041f7c044ac5da1af5433ccf0cde1f231a66708f8e25ed792d4136d2121a534884a34476bd2c3519c7d43710584731235229ae272dcf94d81
+DIST ksshaskpass-5.14.3.tar.xz 21400 BLAKE2B 86606d6de13b785a5b78cbd08e588d88057818b91799aedecee5514e88a34c4cfc4b1cc0910d0ff145963aa74f979f80d17146342f5fc4e64a794cb85f701a0a SHA512 d4aa1870c9e484e8e855d701585076e6ff25af6647e3c97075b3296a4a7603b32833e147dcd8c42073c67ffa9fff77b2f65697bb5885529ce0fd17e29dbe8e76
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.14.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.14.3.ebuild
new file mode 100644
index 000000000000..058e2fe8d646
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.14.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}