summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.12.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 760022a8ac11..e95e15c429e7 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.11.5.tar.xz 23168 BLAKE2B 74d10be7c303d0b7d1d8765e08a89986b4c1745e5f601982dd406cefc7c73ac684c1c05acdd355d45f5078e034ab9971467b4b76c0ae3a94800ce6480fa8c3f0 SHA512 34a8fe5da983a0fcc6d5d223120f2d23e0168a534d29941e83024110eafe981d6c46ee503abfb7bf8e072dc64060eea373c191ef0f8dbc5051cb2d968e6d49d3
DIST ksshaskpass-5.12.0.tar.xz 21272 BLAKE2B 5b2037c239e0f3697364daa31cc3dfd632f882d4729369a44284601001f44edec1df8ca0b6daddcbde05467196e866513b4cc94d2ad7127462934b315e580462 SHA512 f785f6e58bc580eb2b895bebe2a1d9eaccbb8ad9e493eb8f55ffc86a4dc32d609278fcb351c7b33787471e387eb47e6106ddcd0fe2a8fc27ff59e40a41cc5052
+DIST ksshaskpass-5.12.1.tar.xz 21148 BLAKE2B 7ab77527bae0bf3c0c3547bdc0fdc45dc1758c95308f26164c12d9af130f7f5080260981684633010e929908625f56bf7f3505bc4ab4d71d2c40470dc81d5e64 SHA512 210cb8cba185a06d896430011c087b85eb0ca0db6a21f2ceba58d3497cc49acc7a9b67ef31f21bb4627049f34369250575de7e33beb09fb0014cdfe52c8318d8
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.12.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.12.1.ebuild
new file mode 100644
index 000000000000..3009c8d5ff69
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.12.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}