summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-workspace/files/plasma-workspace-5.12.80-tests-optional.patch')
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.12.80-tests-optional.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.12.80-tests-optional.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.12.80-tests-optional.patch
new file mode 100644
index 000000000000..e26b27e8c3be
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.12.80-tests-optional.patch
@@ -0,0 +1,17 @@
+diff --git a/dataengines/notifications/CMakeLists.txt b/dataengines/notifications/CMakeLists.txt
+index 8a90cb59..597b3f7e 100644
+--- a/dataengines/notifications/CMakeLists.txt
++++ b/dataengines/notifications/CMakeLists.txt
+@@ -46,7 +46,8 @@ ecm_qt_declare_logging_category(notifications_test_SRCS HEADER debug.h
+ IDENTIFIER NOTIFICATIONS
+ CATEGORY_NAME kde.dataengine.notifications`
+ DEFAULT_SEVERITY Info)
+-
+-add_executable(notification_test ${notifications_test_SRCS})
+-target_link_libraries(notification_test Qt5::Test Qt5::Core)
+-ecm_mark_as_test(notification_test)
++if(BUILD_TESTING)
++ add_executable(notification_test ${notifications_test_SRCS})
++ target_link_libraries(notification_test Qt5::Test Qt5::Core)
++ ecm_mark_as_test(notification_test)
++endif()