summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plymouth-kcm/plymouth-kcm-5.26.90.ebuild')
-rw-r--r--kde-plasma/plymouth-kcm/plymouth-kcm-5.26.90.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/plymouth-kcm/plymouth-kcm-5.26.90.ebuild b/kde-plasma/plymouth-kcm/plymouth-kcm-5.26.90.ebuild
new file mode 100644
index 000000000000..be1e39986d76
--- /dev/null
+++ b/kde-plasma/plymouth-kcm/plymouth-kcm-5.26.90.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="KDE Plasma control module for Plymouth"
+HOMEPAGE="https://invent.kde.org/plasma/plymouth-kcm"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ sys-boot/plymouth
+"
+RDEPEND="${DEPEND}
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"