summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.19.5-login-button-size.patch36
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.19.5-r1.ebuild (renamed from kde-plasma/plasma-workspace/plasma-workspace-5.19.5.ebuild)1
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.19.5-login-button-size.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.19.5-login-button-size.patch
new file mode 100644
index 000000000000..aa30a4d2cf2a
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.19.5-login-button-size.patch
@@ -0,0 +1,36 @@
+From 9a8fc811282e303ec2f93c978228a85961dae263 Mon Sep 17 00:00:00 2001
+From: Noah Davis <noahadvs@gmail.com>
+Date: Mon, 14 Sep 2020 10:18:57 -0400
+Subject: [PATCH] [sddm-theme/lockscreen] Fix login button size
+
+Some users reported this button becoming too small after KF5.74 was released, but I could not reproduce it myself. However, this code did look suspicious. Hopefully this fixes the issue.
+---
+ lookandfeel/contents/lockscreen/MainBlock.qml | 4 ++--
+ sddm-theme/Login.qml | 5 ++---
+ 2 files changed, 4 insertions(+), 5 deletions(-)
+
+--- a/lookandfeel/contents/lockscreen/MainBlock.qml
++++ b/lookandfeel/contents/lockscreen/MainBlock.qml
+@@ -97,7 +97,8 @@
+ PlasmaComponents.Button {
+ id: loginButton
+ Accessible.name: i18nd("plasma_lookandfeel_org.kde.lookandfeel", "Unlock")
+- implicitHeight: passwordBox.height - units.smallSpacing * 0.5 // otherwise it comes out taller than the password field
++ Layout.preferredHeight: passwordBox.implicitHeight
++ Layout.preferredWidth: loginButton.Layout.preferredHeight
+
+ PlasmaCore.IconItem { // no iconSource because if you take away half a unit (implicitHeight), "go-next" gets cut off
+ anchors.fill: parent
+--- a/sddm-theme/Login.qml
++++ b/sddm-theme/Login.qml
+@@ -112,8 +112,8 @@
+ PlasmaComponents.Button {
+ id: loginButton
+ Accessible.name: i18nd("plasma_lookandfeel_org.kde.lookandfeel", "Log In")
+- implicitHeight: passwordBox.height - units.smallSpacing * 0.5 // otherwise it comes out taller than the password field
+- Layout.rightMargin: 1 // prevents it from extending beyond the username field
++ Layout.preferredHeight: passwordBox.implicitHeight
++ Layout.preferredWidth: loginButton.Layout.preferredHeight
+
+ PlasmaCore.IconItem { // no iconSource because if you take away half a unit (implicitHeight), "go-next" gets cut off
+ anchors.fill: parent
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.19.5.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.19.5-r1.ebuild
index 049c17d6cda0..232540bdbe82 100644
--- a/kde-plasma/plasma-workspace/plasma-workspace-5.19.5.ebuild
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.19.5-r1.ebuild
@@ -127,6 +127,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.14.2-split-libkworkspace.patch"
"${FILESDIR}/${PN}-5.19.2-use-PlasmaExtras.PlaceholderMessage.patch" # KDE-Bug #422684
"${FILESDIR}/${P}-gpsd-3.21.patch" # bug 742392
+ "${FILESDIR}/${P}-login-button-size.patch"
)
RESTRICT+=" test"