summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-sudo/Manifest1
-rw-r--r--lxqt-base/lxqt-sudo/lxqt-sudo-0.16.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-sudo/Manifest b/lxqt-base/lxqt-sudo/Manifest
index a272cb3883b5..b3b04a265449 100644
--- a/lxqt-base/lxqt-sudo/Manifest
+++ b/lxqt-base/lxqt-sudo/Manifest
@@ -1 +1,2 @@
DIST lxqt-sudo-0.15.0.tar.xz 34528 BLAKE2B 50b7b699e85c52b7b55bf559f3d7e239ad5a9ee6031af1bf6e902cd4aa7399e9df88157ef48906b3343e4cf68d6e62912179a26d3fd4e3aa223849fd1088199f SHA512 94c96a1eac5d1ec6e84c99ecbd08e7ecb8184d4e1ada0bce137c2c8d9508cd840b56dae38e3f418cb208a3eae5b3420bf33e0b9a1bb96969f2bd4d207e89304c
+DIST lxqt-sudo-0.16.0.tar.xz 35088 BLAKE2B d19dccfd7f6219473184ba93cbe8179da848216ba8080aa3754600083e8d2a20a55b403a9bddd99fef636a24e36c3ae098e110ff05f0debcbce2953bed2e167e SHA512 425c1bf1a4c2a6fe3933419c77e0d1c5f576902cf5cfd2550890e037c32c3021eb8294831f26690ff2488ed096fcd271d664d9f67e73374559c53e7669089694
diff --git a/lxqt-base/lxqt-sudo/lxqt-sudo-0.16.0.ebuild b/lxqt-base/lxqt-sudo/lxqt-sudo-0.16.0.ebuild
new file mode 100644
index 000000000000..eee04b1e377d
--- /dev/null
+++ b/lxqt-base/lxqt-sudo/lxqt-sudo-0.16.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt GUI frontend for sudo"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.8.0"
+DEPEND="
+ app-admin/sudo
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"