summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest1
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 11b74532469d..75d3b161e8e5 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1 +1,2 @@
DIST lxqt-notificationd-0.13.0.tar.xz 32364 BLAKE2B c43e57e66e2fdd375f25afd68acc428c6204992e48c2b2bf1a692380bcb2f48663c52b3a5a9b17d01a68d6cb57e6779260da3c9e09873baa0a8c7489dfa9c9a7 SHA512 2bc75b840a666e013d914f08719680cf3af7430a6acfb5072facff8bdc964aeef1d5227c68b5a5c5d8a6d6c572632105e3f2f04c517d8e8669eb40b5a0cf0f4d
+DIST lxqt-notificationd-0.14.1.tar.xz 47356 BLAKE2B b80febe059a17e30df4abb81e6d63271b8955211474d80853dc54ea65112081160bf270766654498b50c78c58df4444682e1e9b9cac800c4afb294fdb2fdbaeb SHA512 dcd1892ff66d6beb5c8953c6731f798a59272365fb7439277732b145cc9e6479314415481d9e8aae9fd670d779011c3d7bb3874b05a67cfad2a722f467866795
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild
new file mode 100644
index 000000000000..5b510c9b2b27
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"