summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/afew/afew-1.3.0.ebuild')
-rw-r--r--mail-filter/afew/afew-1.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail-filter/afew/afew-1.3.0.ebuild b/mail-filter/afew/afew-1.3.0.ebuild
new file mode 100644
index 000000000000..8bbdbf2fe275
--- /dev/null
+++ b/mail-filter/afew/afew-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Initial tagging script for Notmuch"
+HOMEPAGE="https://github.com/afewmail/afew"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/dkimpy[${PYTHON_USEDEP}]
+ net-mail/notmuch[python,${PYTHON_USEDEP}]"
+
+DOCS=( "README.rst" )
+
+src_prepare() {
+ sed -r \
+ -e "s/^([[:space:]]+)use_scm_version=.*,$/\1version='${PV}',/" \
+ -e "/^([[:space:]]+)setup_requires=.*,$/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc afew/defaults/afew.config
+}