summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-base/mate-menus/mate-menus-1.22.0.ebuild')
-rw-r--r--mate-base/mate-menus/mate-menus-1.22.0.ebuild27
1 files changed, 4 insertions, 23 deletions
diff --git a/mate-base/mate-menus/mate-menus-1.22.0.ebuild b/mate-base/mate-menus/mate-menus-1.22.0.ebuild
index 9f30adb69d62..41f8745853ea 100644
--- a/mate-base/mate-menus/mate-menus-1.22.0.ebuild
+++ b/mate-base/mate-menus/mate-menus-1.22.0.ebuild
@@ -4,9 +4,8 @@
EAPI=6
GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-inherit python-r1 mate
+inherit mate
if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
@@ -22,11 +21,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
COMMON_DEPEND=">=dev-libs/glib-2.50:2
virtual/libintl
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
- python? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )"
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
RDEPEND="${COMMON_DEPEND}"
@@ -35,30 +30,16 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
-src_prepare() {
- mate_src_prepare
- use python && python_copy_sources
-}
-
src_configure() {
# Do NOT compile with --disable-debug/--enable-debug=no as it disables API
# usage checks.
- mate_py_cond_func_wrap mate_src_configure \
+ mate_src_configure \
--enable-debug=$(usex debug yes minimum) \
- $(use_enable python) \
$(use_enable introspection)
}
-src_compile() {
- mate_py_cond_func_wrap default
-}
-
-src_test() {
- mate_py_cond_func_wrap emake check
-}
-
src_install() {
- mate_py_cond_func_wrap mate_src_install
+ mate_src_install
exeinto /etc/X11/xinit/xinitrc.d/
doexe "${FILESDIR}/10-xdg-menu-mate"