summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-base/mate-settings-daemon')
-rw-r--r--mate-base/mate-settings-daemon/Manifest3
-rw-r--r--mate-base/mate-settings-daemon/files/mate-settings-daemon-1.2.0-syndaemon-mode.patch22
-rw-r--r--mate-base/mate-settings-daemon/files/mate-settings-daemon-1.4.0-netfs-monitor.patch42
-rw-r--r--mate-base/mate-settings-daemon/mate-settings-daemon-1.8.0.ebuild89
-rw-r--r--mate-base/mate-settings-daemon/mate-settings-daemon-1.8.1.ebuild83
-rw-r--r--mate-base/mate-settings-daemon/mate-settings-daemon-1.8.2.ebuild83
-rw-r--r--mate-base/mate-settings-daemon/metadata.xml8
7 files changed, 330 insertions, 0 deletions
diff --git a/mate-base/mate-settings-daemon/Manifest b/mate-base/mate-settings-daemon/Manifest
new file mode 100644
index 000000000000..ca23907af5e8
--- /dev/null
+++ b/mate-base/mate-settings-daemon/Manifest
@@ -0,0 +1,3 @@
+DIST mate-settings-daemon-1.8.0.tar.xz 781648 SHA256 dfe3b86835a099223a6a93e1c367f48fcbbcc4fbc56da193218c71049e7d39b7 SHA512 405fc70b99ab65f70df4ae8a1390f2585d888c8668c620b977577498d3acce4462506be8e57ae2f6a3f61aad041d709429d5f6cd041a69944920ef0300c00f5a WHIRLPOOL 3234d9b523d90397400c7d0e0c21d4e6c96fc11132ddfe144518f0fd13f50e2a222e377f8bdbc53c352bcbb013234296cea152078059a5a0c7a33a8a5f24fa75
+DIST mate-settings-daemon-1.8.1.tar.xz 782508 SHA256 231bc408ea1a3305aeca621a278930ddba032201a1001da2ae239f6324da1106 SHA512 a7b2612719b21f77338e912f3eff52d86daf4f0cedc5854d8e161f74062d4218c5609c3f5885e4428b3fa3247e48830b74422bd991a994d5a7fa088d04f0e745 WHIRLPOOL 90807e0e1932db76bacfef45266d00f37b3881e46515147def9d83c805e8f87b99d6b2fb254c683fd75ce4056b18b1c2fc2678c18eb0bea46bbccc3ecef7d94a
+DIST mate-settings-daemon-1.8.2.tar.xz 782780 SHA256 2d38c9eff00a7ad239613b5f59e95a08705601a64f3a660b34919a4818da9d87 SHA512 46fd2009463c5f4f46ad6941444b42e0146caea0daec8d6ccd253adb08fc8b905419c5763756c05c4ab1404b2eb9b775f7730babe790194e145e5c0a6829f1d1 WHIRLPOOL 09d908b098a7e469c2eb9eecafc5551fd5986d4c0967da62ad2924d5cc309e856ebe4c523a22ef2d844bfeab829049c6f36f6275cb4d82ad48ed4fdd5ce972b5
diff --git a/mate-base/mate-settings-daemon/files/mate-settings-daemon-1.2.0-syndaemon-mode.patch b/mate-base/mate-settings-daemon/files/mate-settings-daemon-1.2.0-syndaemon-mode.patch
new file mode 100644
index 000000000000..a03571a03d0b
--- /dev/null
+++ b/mate-base/mate-settings-daemon/files/mate-settings-daemon-1.2.0-syndaemon-mode.patch
@@ -0,0 +1,22 @@
+diff -burN a/plugins/mouse/msd-mouse-manager.c b/plugins/mouse/msd-mouse-manager.c
+--- a/plugins/mouse/msd-mouse-manager.c 2012-02-28 23:45:55.000000000 +0100
++++ b/plugins/mouse/msd-mouse-manager.c 2012-08-03 20:22:19.204115652 +0200
+@@ -548,7 +548,7 @@
+
+ if (state) {
+ GError *error = NULL;
+- char *args[5];
++ char *args[6];
+
+ if (manager->priv->syndaemon_spawned)
+ return 0;
+@@ -557,7 +557,8 @@
+ args[1] = "-i";
+ args[2] = "0.5";
+ args[3] = "-k";
+- args[4] = NULL;
++ args[4] = "-R";
++ args[5] = NULL;
+
+ if (!g_find_program_in_path (args[0]))
+ return 0;
diff --git a/mate-base/mate-settings-daemon/files/mate-settings-daemon-1.4.0-netfs-monitor.patch b/mate-base/mate-settings-daemon/files/mate-settings-daemon-1.4.0-netfs-monitor.patch
new file mode 100644
index 000000000000..1890c915459a
--- /dev/null
+++ b/mate-base/mate-settings-daemon/files/mate-settings-daemon-1.4.0-netfs-monitor.patch
@@ -0,0 +1,42 @@
+diff -burN a/plugins/housekeeping/msd-disk-space.c b/plugins/housekeeping/msd-disk-space.c
+--- a/plugins/housekeeping/msd-disk-space.c 2012-07-11 03:54:10.000000000 +0200
++++ b/plugins/housekeeping/msd-disk-space.c 2012-08-07 22:54:59.872216471 +0200
+@@ -309,19 +309,38 @@
+ * purpose
+ */
+
++ /* We also ignore network filesystems */
++
+ const gchar *ignore_fs[] = {
++ "adfs",
++ "afs",
+ "auto",
+ "autofs",
++ "autofs4",
++ "cifs",
++ "cxfs",
+ "devfs",
+ "devpts",
+ "ecryptfs",
++ "gfs",
++ "gfs2",
+ "kernfs",
+ "linprocfs",
++ "linsysfs",
++ "lustre",
++ "lustre_lite",
++ "ncpfs",
++ "nfs",
++ "nfs4",
++ "nfsd",
++ "ocfs2",
+ "proc",
+ "procfs",
+ "ptyfs",
++ "rpc_pipefs",
+ "selinuxfs",
+ "linsysfs",
++ "smbfs",
+ "sysfs",
+ "tmpfs",
+ "usbfs",
diff --git a/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.0.ebuild b/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.0.ebuild
new file mode 100644
index 000000000000..14032e87f6ea
--- /dev/null
+++ b/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE Settings Daemon"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="X debug libnotify policykit pulseaudio smartcard"
+
+RDEPEND=">=dev-libs/dbus-glib-0.74:0
+ >=dev-libs/glib-2.17.3:2
+ >=mate-base/libmatekbd-1.8:0
+ >=mate-base/mate-desktop-1.8:0
+ media-libs/fontconfig:1.0
+ >=gnome-base/dconf-0.13.4:0
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11:0
+ x11-libs/libXi:0
+ x11-libs/libXext:0
+ x11-libs/libXxf86misc:0
+ >=x11-libs/libxklavier-5:0
+ virtual/libintl:0
+ libnotify? ( >=x11-libs/libnotify-0.7:0 )
+ policykit? (
+ >=dev-libs/dbus-glib-0.71:0
+ >=sys-apps/dbus-1.1.2:0
+ >=sys-auth/polkit-0.97:0
+ )
+ pulseaudio? (
+ media-libs/libcanberra:0[gtk]
+ >=media-sound/pulseaudio-0.9.15:0
+ )
+ !pulseaudio? (
+ >=media-libs/gstreamer-0.10.1.2:0.10
+ >=media-libs/gst-plugins-base-0.10.1.2:0.10
+ )
+ smartcard? ( >=dev-libs/nss-3.11.2:0 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.37.1:0
+ sys-devel/gettext:0
+ virtual/pkgconfig:0
+ x11-proto/inputproto:0
+ x11-proto/xproto:0"
+
+src_prepare() {
+ # More network filesystems not to monitor, upstream bug #606421
+ epatch "${FILESDIR}/${PN}-1.4.0-netfs-monitor.patch"
+
+ # mouse: Use event driven mode for syndaemon
+ epatch "${FILESDIR}/${PN}-1.2.0-syndaemon-mode.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with libnotify) \
+ $(use_enable debug) \
+ $(use_enable policykit polkit) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable !pulseaudio gstreamer) \
+ $(use_enable smartcard smartcard-support) \
+ $(use_with X x)
+
+ if use pulseaudio; then
+ elog "Building volume media keys using Pulseaudio"
+ else
+ elog "Building volume media keys using GStreamer"
+ fi
+}
+
+DOCS="AUTHORS NEWS ChangeLog"
diff --git a/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.1.ebuild b/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.1.ebuild
new file mode 100644
index 000000000000..1929e117d33e
--- /dev/null
+++ b/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE Settings Daemon"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="X debug libnotify policykit pulseaudio smartcard"
+
+RDEPEND=">=dev-libs/dbus-glib-0.74:0
+ >=dev-libs/glib-2.17.3:2
+ >=mate-base/libmatekbd-1.8:0
+ >=mate-base/mate-desktop-1.8.1:0
+ media-libs/fontconfig:1.0
+ >=gnome-base/dconf-0.13.4:0
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11:0
+ x11-libs/libXi:0
+ x11-libs/libXext:0
+ x11-libs/libXxf86misc:0
+ >=x11-libs/libxklavier-5:0
+ virtual/libintl:0
+ libnotify? ( >=x11-libs/libnotify-0.7:0 )
+ policykit? (
+ >=dev-libs/dbus-glib-0.71:0
+ >=sys-apps/dbus-1.1.2:0
+ >=sys-auth/polkit-0.97:0
+ )
+ pulseaudio? (
+ media-libs/libcanberra:0[gtk]
+ >=media-sound/pulseaudio-0.9.15:0
+ )
+ !pulseaudio? (
+ >=media-libs/gstreamer-0.10.1.2:0.10
+ >=media-libs/gst-plugins-base-0.10.1.2:0.10
+ )
+ smartcard? ( >=dev-libs/nss-3.11.2:0 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.37.1:0
+ sys-devel/gettext:0
+ virtual/pkgconfig:0
+ x11-proto/inputproto:0
+ x11-proto/xproto:0"
+
+src_prepare() {
+ # More network filesystems not to monitor, upstream bug #606421
+ epatch "${FILESDIR}/${PN}-1.4.0-netfs-monitor.patch"
+
+ # mouse: Use event driven mode for syndaemon
+ epatch "${FILESDIR}/${PN}-1.2.0-syndaemon-mode.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with libnotify) \
+ $(use_enable debug) \
+ $(use_enable policykit polkit) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable !pulseaudio gstreamer) \
+ $(use_enable smartcard smartcard-support) \
+ $(use_with X x)
+}
+
+DOCS="AUTHORS NEWS ChangeLog"
diff --git a/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.2.ebuild b/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.2.ebuild
new file mode 100644
index 000000000000..7b8a35c43181
--- /dev/null
+++ b/mate-base/mate-settings-daemon/mate-settings-daemon-1.8.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE Settings Daemon"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X debug libnotify policykit pulseaudio smartcard"
+
+RDEPEND=">=dev-libs/dbus-glib-0.74:0
+ >=dev-libs/glib-2.17.3:2
+ >=mate-base/libmatekbd-1.8:0
+ >=mate-base/mate-desktop-1.8.1:0
+ media-libs/fontconfig:1.0
+ >=gnome-base/dconf-0.13.4:0
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11:0
+ x11-libs/libXi:0
+ x11-libs/libXext:0
+ x11-libs/libXxf86misc:0
+ >=x11-libs/libxklavier-5:0
+ virtual/libintl:0
+ libnotify? ( >=x11-libs/libnotify-0.7:0 )
+ policykit? (
+ >=dev-libs/dbus-glib-0.71:0
+ >=sys-apps/dbus-1.1.2:0
+ >=sys-auth/polkit-0.97:0
+ )
+ pulseaudio? (
+ media-libs/libcanberra:0[gtk]
+ >=media-sound/pulseaudio-0.9.15:0
+ )
+ !pulseaudio? (
+ >=media-libs/gstreamer-0.10.1.2:0.10
+ >=media-libs/gst-plugins-base-0.10.1.2:0.10
+ )
+ smartcard? ( >=dev-libs/nss-3.11.2:0 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.37.1:0
+ sys-devel/gettext:0
+ virtual/pkgconfig:0
+ x11-proto/inputproto:0
+ x11-proto/xproto:0"
+
+src_prepare() {
+ # More network filesystems not to monitor, upstream bug #606421
+ epatch "${FILESDIR}/${PN}-1.4.0-netfs-monitor.patch"
+
+ # mouse: Use event driven mode for syndaemon
+ epatch "${FILESDIR}/${PN}-1.2.0-syndaemon-mode.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with libnotify) \
+ $(use_enable debug) \
+ $(use_enable policykit polkit) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable !pulseaudio gstreamer) \
+ $(use_enable smartcard smartcard-support) \
+ $(use_with X x)
+}
+
+DOCS="AUTHORS NEWS ChangeLog"
diff --git a/mate-base/mate-settings-daemon/metadata.xml b/mate-base/mate-settings-daemon/metadata.xml
new file mode 100644
index 000000000000..d86e8143c78a
--- /dev/null
+++ b/mate-base/mate-settings-daemon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <upstream>
+ <remote-id type="github">mate-desktop/mate-settings-daemon</remote-id>
+ </upstream>
+</pkgmetadata>