summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.10.4-cpupower-4.7.patch46
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.14.1-cpupower-4.7.patch44
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch44
-rw-r--r--mate-base/mate-applets/mate-applets-1.12.1-r5.ebuild102
-rw-r--r--mate-base/mate-applets/mate-applets-1.14.1-r2.ebuild106
-rw-r--r--mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild105
-rw-r--r--mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild96
7 files changed, 543 insertions, 0 deletions
diff --git a/mate-base/mate-applets/files/mate-applets-1.10.4-cpupower-4.7.patch b/mate-base/mate-applets/files/mate-applets-1.10.4-cpupower-4.7.patch
new file mode 100644
index 000000000000..070b41754ed0
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.10.4-cpupower-4.7.patch
@@ -0,0 +1,46 @@
+diff --git a/configure.ac b/configure.ac
+index c867af3..4ff5311 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -416,6 +416,8 @@ fi
+ AM_CONDITIONAL(HAVE_LIBCPUFREQ, test x$have_libcpufreq = xyes)
+ AC_SUBST(LIBCPUFREQ_LIBS)
+
++AC_CHECK_HEADERS([cpupower.h])
++
+ build_cpufreq_applet=no
+
+ if test x$disable_cpufreq = xno; then
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 40c44ba..120693c 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -19,11 +19,16 @@
+ * Authors : Carlos García Campos <carlosgc@gnome.org>
+ */
+
++#include <config.h>
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
+ #include <cpufreq.h>
++#ifdef HAVE_CPUPOWER_H
++#include <cpupower.h>
++#endif
+
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+@@ -111,7 +114,11 @@ cpufreq_monitor_libcpufreq_run (CPUFreqMonitor *monitor)
+ /* Check whether it failed because
+ * cpu is not online.
+ */
++#ifndef HAVE_CPUPOWER_H
+ if (!cpufreq_cpu_exists (cpu)) {
++#else
++ if (cpupower_is_cpu_online (cpu)) {
++#endif
+ g_object_set (G_OBJECT (monitor), "online", FALSE, NULL);
+ return TRUE;
+ }
diff --git a/mate-base/mate-applets/files/mate-applets-1.14.1-cpupower-4.7.patch b/mate-base/mate-applets/files/mate-applets-1.14.1-cpupower-4.7.patch
new file mode 100644
index 000000000000..203f1589a1b2
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.14.1-cpupower-4.7.patch
@@ -0,0 +1,44 @@
+diff --git a/configure.ac b/configure.ac
+index b49d127..6b87389 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -411,6 +411,8 @@ fi
+ AM_CONDITIONAL(HAVE_LIBCPUFREQ, test x$have_libcpufreq = xyes)
+ AC_SUBST(LIBCPUFREQ_LIBS)
+
++AC_CHECK_HEADERS([cpupower.h])
++
+ build_cpufreq_applet=no
+
+ if test x$disable_cpufreq = xno; then
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 4fa9d4c..ba52fde 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -19,12 +19,16 @@
+ * Authors : Carlos García Campos <carlosgc@gnome.org>
+ */
+
++#include <config.h>
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
+-#include <linux/version.h>
+ #include <cpufreq.h>
++#ifdef HAVE_CPUPOWER_H
++#include <cpupower.h>
++#endif
+
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+@@ -112,7 +116,7 @@
+ /* Check whether it failed because
+ * cpu is not online.
+ */
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 7, 0)
++#ifndef HAVE_CPUPOWER_H
+ if (!cpufreq_cpu_exists (cpu)) {
+ #else
+ if (cpupower_is_cpu_online (cpu)) {
diff --git a/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch b/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch
new file mode 100644
index 000000000000..3f4f4fa519f1
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch
@@ -0,0 +1,44 @@
+diff --git a/configure.ac b/configure.ac
+index b49d127..6b87389 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -411,6 +411,8 @@ fi
+ AM_CONDITIONAL(HAVE_LIBCPUFREQ, test x$have_libcpufreq = xyes)
+ AC_SUBST(LIBCPUFREQ_LIBS)
+
++AC_CHECK_HEADERS([cpupower.h])
++
+ build_cpufreq_applet=no
+
+ if test x$disable_cpufreq = xno; then
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 4fa9d4c..ba52fde 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -19,12 +19,16 @@
+ * Authors : Carlos García Campos <carlosgc@gnome.org>
+ */
+
++#include <config.h>
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
+-#include <linux/version.h>
+ #include <cpufreq.h>
++#ifdef HAVE_CPUPOWER_H
++#include <cpupower.h>
++#endif
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+
+@@ -111,7 +115,7 @@
+ /* Check whether it failed because
+ * cpu is not online.
+ */
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 7, 0)
++#ifndef HAVE_CPUPOWER_H
+ if (!cpufreq_cpu_exists (cpu)) {
+ #else
+ if (cpupower_is_cpu_online (cpu)) {
diff --git a/mate-base/mate-applets/mate-applets-1.12.1-r5.ebuild b/mate-base/mate-applets/mate-applets-1.12.1-r5.ebuild
new file mode 100644
index 000000000000..3853add0fe5d
--- /dev/null
+++ b/mate-base/mate-applets/mate-applets-1.12.1-r5.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Applets for the MATE Desktop and Panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X gtk3 ipv6 policykit +upower"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/rarian:0
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.74:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libmateweather-1.6.1[gtk3(-)=]
+ >=dev-libs/libxml2-2.5:2
+ dev-python/pygobject:3
+ >=gnome-base/libgtop-2.11.92:2=
+ >=mate-base/mate-desktop-1.9[gtk3(-)=]
+ >=mate-base/mate-panel-1.7[gtk3(-)=]
+ >=mate-base/mate-settings-daemon-1.6
+ >=sys-apps/dbus-1.1.2:0
+ sys-power/cpupower
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ x11-libs/pango:0
+ virtual/libintl:0
+ !gtk3? (
+ >=gnome-extra/gucharmap-2.32.1:0
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/gtksourceview:2.0
+ >=x11-libs/libwnck-2.30:1
+ )
+ gtk3? (
+ >=gnome-extra/gucharmap-3.0:2.90
+ >=x11-libs/gtk+-3.0:3
+ x11-libs/gtksourceview:3.0
+ >=x11-libs/libwnck-3.0:3
+ )
+ policykit? ( >=sys-auth/polkit-0.92:0 )
+ upower? (
+ || (
+ >=sys-power/upower-0.9.23
+ >=sys-power/upower-pm-utils-0.9.23
+ )
+ )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ dev-libs/libxslt:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+PATCHES=( "${FILESDIR}/${PN}-1.10.4-cpupower-4.7.patch" )
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --with-cpufreq-lib=cpupower \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_with X x) \
+ $(use_with upower) \
+ $(use_enable ipv6) \
+ $(use_enable policykit polkit)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check
+}
+
+src_install() {
+ python_fix_shebang invest-applet
+ mate_src_install
+
+ local APPLETS="accessx-status battstat charpick command cpufreq drivemount
+ geyes invest-applet mateweather multiload null_applet stickynotes
+ timerapplet trashapplet"
+
+ for applet in ${APPLETS}; do
+ docinto ${applet}
+
+ for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
+ [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
+ done
+ done
+}
diff --git a/mate-base/mate-applets/mate-applets-1.14.1-r2.ebuild b/mate-base/mate-applets/mate-applets-1.14.1-r2.ebuild
new file mode 100644
index 000000000000..900d90340920
--- /dev/null
+++ b/mate-base/mate-applets/mate-applets-1.14.1-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Applets for the MATE Desktop and Panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X gtk3 ipv6 policykit +upower"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.74:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libmateweather-1.6.1[gtk3(-)=]
+ >=dev-libs/libxml2-2.5:2
+ dev-python/pygobject:3
+ >=gnome-base/libgtop-2.11.92:2=
+ >=mate-base/mate-desktop-1.9[gtk3(-)=]
+ >=mate-base/mate-panel-1.7[gtk3(-)=]
+ >=net-wireless/wireless-tools-28_pre9:0
+ >=sys-apps/dbus-1.1.2:0
+ sys-power/cpupower
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ x11-libs/pango:0
+ virtual/libintl:0
+ !gtk3? (
+ >=gnome-extra/gucharmap-2.32.1:0
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/gtksourceview:2.0
+ >=x11-libs/libwnck-2.30:1
+ )
+ gtk3? (
+ >=gnome-extra/gucharmap-3.0:2.90
+ >=x11-libs/gtk+-3.0:3
+ x11-libs/gtksourceview:3.0
+ >=x11-libs/libwnck-3.0:3
+ )
+ policykit? ( >=sys-auth/polkit-0.92:0 )
+ upower? (
+ || (
+ >=sys-power/upower-0.9.23
+ >=sys-power/upower-pm-utils-0.9.23
+ )
+ )
+ !!net-analyzer/mate-netspeed"
+
+RDEPEND="${COMMON_DEPEND}
+ >=mate-base/mate-settings-daemon-1.6"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/rarian:0
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ dev-libs/libxslt:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+PATCHES=( "${FILESDIR}/${PN}-1.14.1-cpupower-4.7.patch" )
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --with-cpufreq-lib=cpupower \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_with X x) \
+ $(use_with upower) \
+ $(use_enable ipv6) \
+ $(use_enable policykit polkit)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check
+}
+
+src_install() {
+ python_fix_shebang invest-applet
+ mate_src_install
+
+ local APPLETS="accessx-status battstat charpick command cpufreq drivemount
+ geyes invest-applet mateweather multiload netspeed stickynotes
+ timerapplet trashapplet"
+
+ for applet in ${APPLETS}; do
+ docinto ${applet}
+
+ for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
+ [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
+ done
+ done
+}
diff --git a/mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild b/mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild
new file mode 100644
index 000000000000..d9c8b7e52daf
--- /dev/null
+++ b/mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Applets for the MATE Desktop and Panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X gtk3 ipv6 policykit +upower"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.74:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libmateweather-1.6.1[gtk3(-)=]
+ >=dev-libs/libxml2-2.5:2
+ dev-python/pygobject:3
+ >=gnome-base/libgtop-2.11.92:2=
+ >=mate-base/mate-panel-1.7[gtk3(-)=]
+ >=net-wireless/wireless-tools-28_pre9:0
+ >=sys-apps/dbus-1.1.2:0
+ sys-power/cpupower
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ x11-libs/pango:0
+ virtual/libintl:0
+ !gtk3? (
+ >=gnome-extra/gucharmap-2.32.1:0
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/gtksourceview:2.0
+ >=x11-libs/libwnck-2.30:1
+ )
+ gtk3? (
+ >=gnome-extra/gucharmap-3.0:2.90
+ >=x11-libs/gtk+-3.0:3
+ x11-libs/gtksourceview:3.0
+ >=x11-libs/libwnck-3.0:3
+ )
+ policykit? ( >=sys-auth/polkit-0.97:0 )
+ upower? (
+ || (
+ >=sys-power/upower-0.9.23
+ >=sys-power/upower-pm-utils-0.9.23
+ )
+ )
+ !!net-analyzer/mate-netspeed"
+
+RDEPEND="${COMMON_DEPEND}
+ >=mate-base/mate-settings-daemon-1.6"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/rarian:0
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ dev-libs/libxslt:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+PATCHES=( "${FILESDIR}/${PN}-1.16.0-cpupower-4.7.patch" )
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --with-cpufreq-lib=cpupower \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_with X x) \
+ $(use_with upower) \
+ $(use_enable ipv6) \
+ $(use_enable policykit polkit)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check
+}
+
+src_install() {
+ python_fix_shebang invest-applet
+ mate_src_install
+
+ local APPLETS="accessx-status battstat charpick command cpufreq drivemount
+ geyes invest-applet mateweather multiload netspeed stickynotes
+ timerapplet trashapplet"
+
+ for applet in ${APPLETS}; do
+ docinto ${applet}
+
+ for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
+ [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
+ done
+ done
+}
diff --git a/mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild b/mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild
new file mode 100644
index 000000000000..4db7d9bb26fc
--- /dev/null
+++ b/mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Applets for the MATE Desktop and Panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X ipv6 policykit +upower"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.74:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libmateweather-1.17.0
+ >=dev-libs/libxml2-2.5:2
+ dev-python/pygobject:3
+ >=gnome-base/libgtop-2.12.0:2=
+ >=gnome-extra/gucharmap-3.0:2.90
+ >=mate-base/mate-panel-1.17.0
+ >=net-wireless/wireless-tools-28_pre9:0
+ >=sys-apps/dbus-1.1.2:0
+ sys-power/cpupower
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.14:3
+ x11-libs/gtksourceview:3.0
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ >=x11-libs/libwnck-3.0:3
+ x11-libs/pango:0
+ virtual/libintl:0
+ policykit? ( >=sys-auth/polkit-0.97:0 )
+ upower? (
+ || (
+ >=sys-power/upower-0.9.23
+ >=sys-power/upower-pm-utils-0.9.23
+ )
+ )
+ !!net-analyzer/mate-netspeed"
+
+RDEPEND="${COMMON_DEPEND}
+ >=mate-base/mate-settings-daemon-1.6"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/rarian:0
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ dev-libs/libxslt:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+PATCHES=( "${FILESDIR}/${PN}-1.16.0-cpupower-4.7.patch" )
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --with-cpufreq-lib=cpupower \
+ $(use_with X x) \
+ $(use_with upower) \
+ $(use_enable ipv6) \
+ $(use_enable policykit polkit)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check
+}
+
+src_install() {
+ python_fix_shebang invest-applet
+ mate_src_install
+
+ local APPLETS="accessx-status battstat charpick command cpufreq drivemount
+ geyes invest-applet mateweather multiload netspeed stickynotes
+ timerapplet trashapplet"
+
+ for applet in ${APPLETS}; do
+ docinto ${applet}
+
+ for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
+ [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
+ done
+ done
+}