summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-extra/mate-indicator-applet')
-rw-r--r--mate-extra/mate-indicator-applet/Manifest1
-rw-r--r--mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild37
-rw-r--r--mate-extra/mate-indicator-applet/metadata.xml3
3 files changed, 41 insertions, 0 deletions
diff --git a/mate-extra/mate-indicator-applet/Manifest b/mate-extra/mate-indicator-applet/Manifest
index 5d144731002b..1f098b232e9b 100644
--- a/mate-extra/mate-indicator-applet/Manifest
+++ b/mate-extra/mate-indicator-applet/Manifest
@@ -1 +1,2 @@
DIST mate-indicator-applet-1.10.0.tar.xz 317840 SHA256 36d0e0fc40fd274e8874c3c0c85cca9d52aa2e692cab82cbb7d411233773dea5 SHA512 84b1e7a8dc788a7b8f72a83e6045f6b65d1c703de8207c2944c28b5062d64cc7fabd74c86370d0a9c13baa8b47a376e6d3014f329c107c9d72644505c265679b WHIRLPOOL 660da18f1d21dd6e8a506d6712ad1c32d6567f99540154b3a6878045fbc3c733987b2d4a517406426ce42f69f5c1cf97fce199f327c1361da912ac6560d33654
+DIST mate-indicator-applet-1.12.1.tar.xz 317984 SHA256 4a55e539f129a23e3471b7f25f8dbbd92ea7330c0e90c26e42396db17713b40e SHA512 446ce32e8db22b153c7786292749645715e43c134e7fa00f81b7782a48163745307d396dbdd7765a63ec9514bec2f032f681028c55264e0fcf879c5e26fc9433 WHIRLPOOL e4fdcee746c5409ee751d573e8aae8b56dbb20f8c875d2d4102f459fb569e539ae79480f09bf5cd6e534d1e154f08913cb99b6d7993fc33a59a14a60273a4a44
diff --git a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..0585d9aa084b
--- /dev/null
+++ b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate versionator
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE indicator applet"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="gtk3"
+
+RDEPEND="
+ >=mate-base/mate-panel-1.8[gtk3(-)=]
+ !gtk3? (
+ >=dev-libs/libindicator-0.3.90:0
+ >=x11-libs/gtk+-2.24:2
+ )
+ gtk3? (
+ >=dev-libs/libindicator-0.3.90:3
+ >=x11-libs/gtk+-3.0:3
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0)
+}
diff --git a/mate-extra/mate-indicator-applet/metadata.xml b/mate-extra/mate-indicator-applet/metadata.xml
index effcbc83d285..06b9073ab576 100644
--- a/mate-extra/mate-indicator-applet/metadata.xml
+++ b/mate-extra/mate-indicator-applet/metadata.xml
@@ -5,6 +5,9 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
+ <use>
+ <flag name="gtk3">Build with GTK+3 instead of GTK+2</flag>
+ </use>
<upstream>
<remote-id type="github">mate-desktop/mate-indicator-applet</remote-id>
</upstream>