summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/caja-hide/Manifest1
-rw-r--r--mate-extra/caja-hide/caja-hide-0.9.0.ebuild38
-rw-r--r--mate-extra/caja-hide/files/caja-hide-0.9.0-py3-support.patch20
-rw-r--r--mate-extra/caja-hide/metadata.xml14
4 files changed, 73 insertions, 0 deletions
diff --git a/mate-extra/caja-hide/Manifest b/mate-extra/caja-hide/Manifest
new file mode 100644
index 000000000000..3a317206fc00
--- /dev/null
+++ b/mate-extra/caja-hide/Manifest
@@ -0,0 +1 @@
+DIST caja-hide-0.9.0.tar.gz 17487 BLAKE2B 182a4e65745a6c3dbbc40121d95f7b5b34b4660ceb9fcffc60ddd51bdc3949191b7eafa258950b0a6b9a6befd63e4b6842481f20ba31b4bfab0668c261e87470 SHA512 86a3d5a661a731caf740c4086ffc041f9f5cb21f996bc21d92cf5d53df108d6d14b753165ee992f3d5574957850f041d03e4d78447fb4db67bf989f16eb5471c
diff --git a/mate-extra/caja-hide/caja-hide-0.9.0.ebuild b/mate-extra/caja-hide/caja-hide-0.9.0.ebuild
new file mode 100644
index 000000000000..029a1ed15148
--- /dev/null
+++ b/mate-extra/caja-hide/caja-hide-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+inherit python-single-r1
+
+MY_PN="Caja-hide"
+
+DESCRIPTION="Hide files without renaming them in MATE's Caja"
+HOMEPAGE="https://github.com/Fred-Barclay/Caja-hide"
+SRC_URI="https://github.com/Fred-Barclay/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep 'dev-python/future[${PYTHON_MULTI_USEDEP}]')
+ dev-python/python-caja[${PYTHON_SINGLE_USEDEP}]
+ x11-misc/xautomation
+"
+BDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-py3-support.patch"
+)
+
+src_install() {
+ insinto /usr/share/caja-python/extensions
+ doins src/caja-hide.py
+}
diff --git a/mate-extra/caja-hide/files/caja-hide-0.9.0-py3-support.patch b/mate-extra/caja-hide/files/caja-hide-0.9.0-py3-support.patch
new file mode 100644
index 000000000000..1e8e9994456e
--- /dev/null
+++ b/mate-extra/caja-hide/files/caja-hide-0.9.0-py3-support.patch
@@ -0,0 +1,20 @@
+# futurized
+--- a/src/caja-hide.py
++++ b/src/caja-hide.py
+@@ -1,3 +1,6 @@
++from __future__ import absolute_import
++from __future__ import division
++from __future__ import unicode_literals
+ # Caja Hide - Extension for Caja to hide files without renaming them
+ # Copyright (C) 2015-2016 Caja Hide authors.
+ #
+@@ -14,6 +17,9 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
++from future import standard_library
++standard_library.install_aliases()
++from builtins import *
+ import os
+ from gi.repository import Caja, GObject
+ from gettext import ngettext, locale, bindtextdomain, textdomain
diff --git a/mate-extra/caja-hide/metadata.xml b/mate-extra/caja-hide/metadata.xml
new file mode 100644
index 000000000000..81973b835302
--- /dev/null
+++ b/mate-extra/caja-hide/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>mate@gentoo.org</email>
+ <name>Gentoo MATE Desktop</name>
+ </maintainer>
+ <longdescription lang="en">
+ An extension for Caja that hiding files without renaming them
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Fred-Barclay/caja-hide</remote-id>
+ </upstream>
+</pkgmetadata>