summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts/noto/noto-20170530.ebuild')
-rw-r--r--media-fonts/noto/noto-20170530.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-fonts/noto/noto-20170530.ebuild b/media-fonts/noto/noto-20170530.ebuild
new file mode 100644
index 000000000000..8cf71ee3ab27
--- /dev/null
+++ b/media-fonts/noto/noto-20170530.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://www.google.com/get/noto/"
+
+# https://noto-website.storage.googleapis.com/pkgs/Noto-hinted.zip
+# Version number based on the timestamp of most recently updated font in the zip.
+# When bumping, remove *CJK* and create a tarball (xz -9 gives the most
+# compressed tarball)
+SRC_URI="https://dev.gentoo.org/~pacho/noto/${P}.tar.xz"
+
+LICENSE="OFL-1.1" # https://github.com/googlei18n/noto-fonts/blob/master/NEWS
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cjk"
+
+RDEPEND="cjk? ( >=media-fonts/noto-cjk-${PV} )"
+RESTRICT="binchecks strip"
+
+FONT_S="${S}"
+FONT_SUFFIX="ttf"