summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/alembic')
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.8.6-r1.ebuild4
-rw-r--r--media-gfx/alembic/alembic-1.8.8.ebuild (renamed from media-gfx/alembic/alembic-1.8.6.ebuild)19
3 files changed, 11 insertions, 13 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index 4810c74e5789..e6378a9716fe 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.8.6.tar.gz 868945 BLAKE2B 1ac30ffa75a4b8bbb3f32820e6f67cebcd894465f16cd12ee0396c88611af821b13973f46228fd59726c6bc0cc8885afd4de81a0cebaa0f94cb30fd9daba9885 SHA512 6371b830242be90d4ea833248df5fd42d9e713e305d15eb1383d04410319acdae5743d48d65e8f75f1cedce777d2af7d969cde095f678b17322c19f1c69f477b
+DIST alembic-1.8.8.tar.gz 933258 BLAKE2B 4f56f5addcf153407da14d6646255ee35b1126b307179fbcfa2c13398825680652b557772db0a08906d04a9bd46c1fa82862a65367d9ce162f2b9d948ff9b701 SHA512 02b7bf5782e83efb08a8653f130b02565fa997e857dbd8d0523e1b218ff58d929fbf9690db0980e8101a31f01a67341b6000af8794538890ef7d759fe0289e2f
diff --git a/media-gfx/alembic/alembic-1.8.6-r1.ebuild b/media-gfx/alembic/alembic-1.8.6-r1.ebuild
index 1c389cb6e29c..368d5ac0b165 100644
--- a/media-gfx/alembic/alembic-1.8.6-r1.ebuild
+++ b/media-gfx/alembic/alembic-1.8.6-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{11..12} )
inherit cmake python-single-r1
diff --git a/media-gfx/alembic/alembic-1.8.6.ebuild b/media-gfx/alembic/alembic-1.8.8.ebuild
index de6bc765bcef..72f906df2218 100644
--- a/media-gfx/alembic/alembic-1.8.6.ebuild
+++ b/media-gfx/alembic/alembic-1.8.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{11..13} )
inherit cmake python-single-r1
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="examples hdf5 python test"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -23,7 +23,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
${PYTHON_DEPS}
- dev-libs/imath:=
+ >=dev-libs/imath-3.1.11-r1:=
python? ( dev-libs/imath:=[python,${PYTHON_SINGLE_USEDEP}] )
hdf5? (
>=sci-libs/hdf5-1.10.2:=[zlib(+)]
@@ -33,15 +33,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-1.8.5-set-correct-libdir.patch )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.6-py312.patch"
-DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
+)
-src_prepare() {
- cmake_src_prepare
- # Tests are broken with python 3.11. See also: https://github.com/alembic/alembic/issues/411
- cmake_run_in "${S}/python/PyAlembic" cmake_comment_add_subdirectory Tests
-}
+DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
src_configure() {
local mycmakeargs=(