summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/colorhug-client')
-rw-r--r--media-gfx/colorhug-client/Manifest2
-rw-r--r--media-gfx/colorhug-client/colorhug-client-0.2.5.ebuild54
-rw-r--r--media-gfx/colorhug-client/colorhug-client-0.2.7.ebuild52
-rw-r--r--media-gfx/colorhug-client/metadata.xml10
4 files changed, 118 insertions, 0 deletions
diff --git a/media-gfx/colorhug-client/Manifest b/media-gfx/colorhug-client/Manifest
new file mode 100644
index 000000000000..7b504f959b4f
--- /dev/null
+++ b/media-gfx/colorhug-client/Manifest
@@ -0,0 +1,2 @@
+DIST colorhug-client-0.2.5.tar.xz 799552 SHA256 215d7d493c06030611584f84fc2d06d31c1124e8756c2c3725b241bb8c8f8449 SHA512 68eb99bdbe4739ac74b9cbb80b97af05874277bfa3fc0aefc98c1e8fe805e719109e2fc933430c1d5ba4a32490d331a41a75203022e4c433b1916c68b86b07ac WHIRLPOOL a8535198e6257d683ea06f828f18097f8c201c22c8a00a654eee30c83ab6a12b85f29c511421ba051ed2c078d0a8bbc568c4a5f5761f60cecfb45a2d964878f9
+DIST colorhug-client-0.2.7.tar.xz 884696 SHA256 16965e11f6983c0cef88c321d9d806fd750013849f4b84006b42063b6d3bb16b SHA512 06c7c44d1dd5f5e39e1e213fdbe45ef0a50fefbde56e05146ae99f32a94e897cc68c65e5856bc7391ef6bfe965b4c420b05add21715607c1f51af1b498ea05f6 WHIRLPOOL fff3c1d50520cb98bfe1189a273edbbb6252c5c005ff84ebeaa2df8f382ab3d815468f1b05987addc983a36454de20529efc381fbe0bda0979ae5d370c3675db
diff --git a/media-gfx/colorhug-client/colorhug-client-0.2.5.ebuild b/media-gfx/colorhug-client/colorhug-client-0.2.5.ebuild
new file mode 100644
index 000000000000..9439b4a56e7c
--- /dev/null
+++ b/media-gfx/colorhug-client/colorhug-client-0.2.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit bash-completion-r1 eutils gnome2
+
+DESCRIPTION="Client tools for the ColorHug display colorimeter"
+HOMEPAGE="http://www.hughski.com/"
+SRC_URI="http://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.31.10:2
+ >=dev-libs/libgusb-0.2.2
+ media-libs/lcms:2
+ >=media-libs/libcanberra-0.10[gtk3]
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-3.11.2:3
+ >=x11-misc/colord-1.2.6:0=
+ >=x11-libs/colord-gtk-0.1.24
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-sgml-dtd:4.1
+ app-text/docbook-sgml-utils
+ app-text/yelp-tools
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+# docbook stuff needed for man pages
+
+src_prepare() {
+ # Fix .desktop
+ sed -e '/Terminal=/ d' -i data/colorhug-docs.desktop || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # introspection checked but not needed by anything
+ gnome2_src_configure --disable-introspection
+}
+
+src_install() {
+ gnome2_src_install bashcompletiondir="$(get_bashcompdir)"
+}
diff --git a/media-gfx/colorhug-client/colorhug-client-0.2.7.ebuild b/media-gfx/colorhug-client/colorhug-client-0.2.7.ebuild
new file mode 100644
index 000000000000..13246537f320
--- /dev/null
+++ b/media-gfx/colorhug-client/colorhug-client-0.2.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit bash-completion-r1 eutils gnome2
+
+DESCRIPTION="Client tools for the ColorHug display colorimeter"
+HOMEPAGE="http://www.hughski.com/"
+SRC_URI="http://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# Tests need valgrind, that needs glibc with debugging symbols
+RESTRICT="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.31.10:2
+ >=dev-libs/libgusb-0.2.2
+ media-libs/lcms:2
+ >=media-libs/libcanberra-0.10[gtk3]
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-3.11.2:3
+ >=x11-misc/colord-1.2.9:0=
+ >=x11-libs/colord-gtk-0.1.24
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-sgml-dtd:4.1
+ app-text/docbook-sgml-utils
+ app-text/yelp-tools
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+# docbook stuff needed for man pages
+
+src_configure() {
+ # introspection checked but not needed by anything
+ # Install completions manually to prevent dependency on bash-completion, bug #546166
+ gnome2_src_configure --disable-introspection --disable-bash-completion
+}
+
+src_install() {
+ gnome2_src_install
+ dobashcomp data/bash/colorhug-cmd
+}
diff --git a/media-gfx/colorhug-client/metadata.xml b/media-gfx/colorhug-client/metadata.xml
new file mode 100644
index 000000000000..8b406a44083e
--- /dev/null
+++ b/media-gfx/colorhug-client/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+ <maintainer>
+ <email>gregkh@gentoo.org</email>
+ <name>Greg Kroah-Hartman</name>
+ <description>Please CC him on bugs and assign to herd</description>
+ </maintainer>
+</pkgmetadata>