summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/geeqie')
-rw-r--r--media-gfx/geeqie/files/geeqie-1.6-yelp.patch25
-rw-r--r--media-gfx/geeqie/geeqie-1.6.ebuild4
2 files changed, 28 insertions, 1 deletions
diff --git a/media-gfx/geeqie/files/geeqie-1.6-yelp.patch b/media-gfx/geeqie/files/geeqie-1.6-yelp.patch
new file mode 100644
index 000000000000..e1d7797d1d50
--- /dev/null
+++ b/media-gfx/geeqie/files/geeqie-1.6-yelp.patch
@@ -0,0 +1,25 @@
+From a33d8c40e9e56597f68e83be3336036992996738 Mon Sep 17 00:00:00 2001
+From: Matthew Miller <mattdm@mattdm.org>
+Date: Thu, 8 Apr 2021 20:21:39 -0400
+Subject: [PATCH] Fix doc building with newer yelp
+
+This adds `-i`, because otherwise it will complain about missing files (which
+we copy into place later), and adds a trailing slash to the output directory,
+because `yelp-build` now puts the files into the wrong place otherwise.
+---
+ doc/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 3d044bd8..78b96233 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -7,7 +7,7 @@ EXTRA_DIST = docbook2html.sh docbook icons
+ html/GuideIndex.html: docbook/GuideIndex.xml
+ rm -rf html; mkdir html; cp $(srcdir)/icons/* html/
+ if [ -x "$(GNOME_DOC_TOOL)" ]; then \
+- "$(GNOME_DOC_TOOL)" html -o html $(srcdir)/docbook/GuideIndex.xml ; \
++ "$(GNOME_DOC_TOOL)" html -i -o html/ $(srcdir)/docbook/GuideIndex.xml ; \
+ else \
+ echo "yelp-tools not found, html is not built" ; \
+ fi
diff --git a/media-gfx/geeqie/geeqie-1.6.ebuild b/media-gfx/geeqie/geeqie-1.6.ebuild
index 39216c027930..1ba491ef5cd1 100644
--- a/media-gfx/geeqie/geeqie-1.6.ebuild
+++ b/media-gfx/geeqie/geeqie-1.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,6 +42,8 @@ REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
gpu-accel? ( gtk3 )
map? ( gpu-accel )"
+PATCHES=( "${FILESDIR}"/${P}-yelp.patch )
+
src_prepare() {
default