summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gif2apng/gif2apng-1.9.ebuild')
-rw-r--r--media-gfx/gif2apng/gif2apng-1.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/gif2apng/gif2apng-1.9.ebuild b/media-gfx/gif2apng/gif2apng-1.9.ebuild
new file mode 100644
index 000000000000..f117e2e2715f
--- /dev/null
+++ b/media-gfx/gif2apng/gif2apng-1.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="create an APNG from a GIF"
+HOMEPAGE="http://sourceforge.net/projects/gif2apng/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}