summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pencil')
-rw-r--r--media-gfx/pencil/Manifest1
-rw-r--r--media-gfx/pencil/files/pencil-0.4.4_beta-gcc461.patch14
-rw-r--r--media-gfx/pencil/metadata.xml10
-rw-r--r--media-gfx/pencil/pencil-0.4.4_beta.ebuild42
4 files changed, 67 insertions, 0 deletions
diff --git a/media-gfx/pencil/Manifest b/media-gfx/pencil/Manifest
new file mode 100644
index 000000000000..0b12434f7f53
--- /dev/null
+++ b/media-gfx/pencil/Manifest
@@ -0,0 +1 @@
+DIST pencil-0.4.4b-src.zip 1147003 SHA256 8a1373e745d9c039e15c7b3f0c1846190fcc4621306b2dd507c31ac31de64303
diff --git a/media-gfx/pencil/files/pencil-0.4.4_beta-gcc461.patch b/media-gfx/pencil/files/pencil-0.4.4_beta-gcc461.patch
new file mode 100644
index 000000000000..d0aa8936b8fd
--- /dev/null
+++ b/media-gfx/pencil/files/pencil-0.4.4_beta-gcc461.patch
@@ -0,0 +1,14 @@
+--- src/graphics/vector/beziercurve.cpp 2007-07-14 21:41:33.000000000 +0200
++++ src/graphics/vector/beziercurve.cpp 2011-08-29 16:19:08.930675072 +0200
+@@ -700,9 +700,9 @@
+ R1.setTopLeft(P1); R1.setBottomRight(Q1);
+ R2.setTopLeft(P2); R2.setBottomRight(Q2);
+
+- //QPointF intersectionPoint = QPointF(50.0, 50.0); // bogus point
++ QPointF intersectionPoint = QPointF(50.0, 50.0); // bogus point
+ //QPointF* intersection = &intersectionPoint;
+- QPointF* cubicIntersection = &QPointF(50.0, 50.0); // bogus point
++ QPointF* cubicIntersection = &intersectionPoint; // bogus point
+ if( R1.intersects(R2) || L2.intersect(L1, cubicIntersection) == QLineF::BoundedIntersection ) {
+ //if(L2.intersect(L1, intersection) == QLineF::BoundedIntersection) {
+ //qDebug() << " FOUND rectangle intersection ";
diff --git a/media-gfx/pencil/metadata.xml b/media-gfx/pencil/metadata.xml
new file mode 100644
index 000000000000..c7699071b168
--- /dev/null
+++ b/media-gfx/pencil/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pencil-planner</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/pencil/pencil-0.4.4_beta.ebuild b/media-gfx/pencil/pencil-0.4.4_beta.ebuild
new file mode 100644
index 000000000000..e26e14f04c0c
--- /dev/null
+++ b/media-gfx/pencil/pencil-0.4.4_beta.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils qt4-r2
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="A Qt4 based animation and drawing program"
+HOMEPAGE="http://www.pencil-animation.org/"
+SRC_URI="mirror://sourceforge/pencil-planner/${MY_P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ >=media-libs/ming-0.4.3"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}-source
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc461.patch
+ sed -i s:SWFSprite:SWFMovieClip:g src/external/flash/flash.{cpp,h} || die
+}
+
+src_install() {
+ # install target not yet provided
+ #emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ newbin Pencil ${PN} || die "dobin failed"
+
+ dodoc README TODO || die
+
+ mv "${S}"/icons/icon.png "${S}"/icons/${PN}.png
+ doicon "${S}"/icons/${PN}.png || die "doicon failed"
+ make_desktop_entry ${PN} Pencil ${PN} Graphics
+}