summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pngtoico/pngtoico-1.0.1-r1.ebuild')
-rw-r--r--media-gfx/pngtoico/pngtoico-1.0.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/pngtoico/pngtoico-1.0.1-r1.ebuild b/media-gfx/pngtoico/pngtoico-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..39f6dafdc1c3
--- /dev/null
+++ b/media-gfx/pngtoico/pngtoico-1.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Convert png images to MS ico format"
+HOMEPAGE="http://www.kernel.org/pub/software/graphics/pngtoico/"
+SRC_URI="mirror://kernel/software/graphics/pngtoico/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=">=media-libs/libpng-1.4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}