summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/sam2p/files/sam2p-configure-strip.patch')
-rw-r--r--media-gfx/sam2p/files/sam2p-configure-strip.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/sam2p/files/sam2p-configure-strip.patch b/media-gfx/sam2p/files/sam2p-configure-strip.patch
new file mode 100644
index 000000000000..be78fad0f736
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-configure-strip.patch
@@ -0,0 +1,30 @@
+diff --git a/Makefile b/Makefile
+index 1433167..b662e33 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,12 +28,13 @@ ifeq ($(MAKECMDGOALS),Makedep.force)
+ MAKE_DIST=000
+ endif
+
++GCC_STRIP ?= -s
+ BASH=bash
+ PERL_BADLANG=x
+ export PERL_BADLANG
+
+ CXXX=$(CXD_assert)
+-LDALL=$(LDXX) -s $(LDFLAGS) $(LIBS)
++LDALL=$(LDXX) $(GCC_STRIP) $(LDFLAGS) $(LIBS)
+ ifeq ($(ENABLE_DEBUG), no)
+ CXXX=$(CXD_no)
+ endif
+@@ -101,8 +102,8 @@ IDE_MODES := release debug
+ IDE_TARGETS_debug := $(patsubst %,%.yes, $(TARGETS))
+ IDE_TARGETS_release := $(TARGETS)
+
+-CXD_assert =$(CXX) -s -O2
+-CXD_no =$(CXX) -s -DNDEBUG -O3
++CXD_assert =$(CXX) $(GCC_STRIP) $(CXXFLAGS)
++CXD_no =$(CXX) $(GCC_STRIP) $(CXXFLAGS)
+ # CXD_yes =$(CXX) $(GFLAG) -lefence
+ CXD_yes =$(CXX) $(GFLAG)
+ CXD_checker=checkerg++ $(GFLAG)