summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/sane-backends/sane-backends-9999.ebuild')
-rw-r--r--media-gfx/sane-backends/sane-backends-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/media-gfx/sane-backends/sane-backends-9999.ebuild b/media-gfx/sane-backends/sane-backends-9999.ebuild
index 2af175b6e7fa..9604d38a5827 100644
--- a/media-gfx/sane-backends/sane-backends-9999.ebuild
+++ b/media-gfx/sane-backends/sane-backends-9999.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit autotools eutils flag-o-matic multilib multilib-minimal udev user toolchain-funcs
+inherit eutils flag-o-matic multilib multilib-minimal udev user toolchain-funcs
# gphoto and v4l are handled by their usual USE flags.
# The pint backend was disabled because I could not get it to compile.
@@ -121,7 +121,7 @@ HOMEPAGE="http://www.sane-project.org/"
case ${PV} in
9999)
EGIT_REPO_URI="git://anonscm.debian.org/sane/sane-backends.git"
- inherit git-r3
+ inherit git-r3 autotools
;;
*_pre*)
MY_P="${PN}-git${PV#*_pre}"
@@ -131,7 +131,8 @@ case ${PV} in
;;
*)
MY_P=${P}
- SRC_URI="https://alioth.debian.org/frs/download.php/file/3958/${P}.tar.gz"
+ FRS_ID="4146"
+ SRC_URI="https://alioth.debian.org/frs/download.php/file/${FRS_ID}/${P}.tar.gz"
;;
esac
@@ -193,8 +194,10 @@ src_prepare() {
EOF
epatch "${FILESDIR}"/${PN}-1.0.24-saned_pidfile_location.patch
epatch "${FILESDIR}"/${PN}-1.0.25-disable-usb-tests.patch
- mv configure.{in,ac} || die
- AT_NOELIBTOOLIZE=yes eautoreconf
+ if [[ ${PV} == "9999" ]] ; then
+ mv configure.{in,ac} || die
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ fi
# Fix for "make check". Upstream sometimes forgets to update this.
local ver=$(./configure --version | awk '{print $NF; exit 0}')